题目描述
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.
Input
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.
Output
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output “N/A”.
Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A
题目解析
根据四个成绩分别进行排序,注意成绩相同的序号相同,最后将其装入map中方便快速查找。但是我的代码总是过不了第三个测试点,求大神解答。
感谢_Occult_的热心帮忙,查出问题所在。是我理解错了排序,虽然相同分数的序号相同,但是会使后面的序号变大。
代码
#include<iostream>
#include<vector>
#include<algorithm>
#include<map>
using namespace std;
struct stud
{
int id;
vector<int> grades = vector<int>(4, 0);//按照ACME的顺序储存成绩
vector<int> ranks=vector<int>(4,0);//按照ACME的顺序储存排名
};
int main()
{
vector<stud>students;
int N, K;
cin >> N >> K;
for (int i = 0; i < N; ++i)
{
stud mem;
scanf("%d %d %d %d", &mem.id, &mem.grades[1], &mem.grades[2], &mem.grades[3]);//读入C M E
mem.grades[0] = mem.grades[1] + mem.grades[2] + mem.grades[3] ;//计算CME的和作为平均值
students.push_back(mem);
}
for (int i = 0; i < 4; ++i)
{
sort(students.begin(), students.end(), [i](stud &a, stud &b) {return a.grades[i] > b.grades[i]; });
int cnt = 1;
for (int j = 0; j < N; ++j)
{
if (j > 0 && students[j].grades[i] < students[j - 1].grades[i])
//++cnt;//如果成绩相同则排名相同
cnt=j+1;//改正后
students[j].ranks[i] = cnt;
}
}
map<int, vector<int> >students_map;
for (int i = 0; i < N; ++i)
{
students_map[students[i].id] = students[i].ranks;
}
char course[4] = {'A','C','M','E'};
for (int i = 0; i < K; ++i)
{
int id;
cin >> id;
if (students_map.count(id))//判断是否存在此id
{
int min_rank = 0;//按照ACME的优先顺序找最高排名
for (int j = 1; j < 4; j++)
{
if (students_map[id][j]<students_map[id][min_rank])
{
min_rank = j;
}
}
cout << students_map[id][min_rank] << " " << course[min_rank] << endl;
}
else
{
cout << "N/A" << endl;
}
}
system("pause");
return 0;
}