【PAT】A1012

22 篇文章 0 订阅
/*
*时间:2018年5月3日21:29:29-2018年5月3日22:36:27
*题目:1012.The Best Rank
*分数:25
*编译器:g++
*题目描述:

To evaluate the performance of our first year CS majored students, we consider their grades
 of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra),
 and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- 
 that is, among the four ranks with respect to the three courses and the average grade, we print 
 the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C 
Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last
 one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers 
N and M (<=2000), which are the total number of students, and the number of students who would
 check their ranks, respectively. Then N lines follow, each contains a student ID which is a string 
 of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in 
 the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the 
corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more 
ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".
Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A
*/
//甲级的难度有点体现出来了
//思路:四个sort来排序,排序的后给每个对应的学科编号排名,NOTE:相同分数的排名相同
//然后按题目的要求,按照ACME的priority输出最高的排名
#include <iostream>
using namespace std;
#include <string.h>
#include <algorithm>

struct student{//结构体包含每一种ID,每门课的成绩以及排名
	string ID;
	int C;
	int M;
	int E;
	double A;
	int C_rank;
	int M_rank;
	int E_rank;
	int A_rank;
};
//每门科目的排序函数
bool cmp_C(student a, student b)
{
	return (a.C > b.C);
}
bool cmp_M(student a, student b)
{
	return (a.M > b.M);
}
bool cmp_E(student a, student b)
{
	return (a.E > b.E);
}
bool cmp_A(student a, student b)
{
	return (a.A > b.A);
}
int main()
{
	int M, N;
	cin>>M>>N;
	student stu[M];
	string stu_ID[N];
	for (int i=0; i<M; i++)//输入,并且计算平局分
	{
		cin>>stu[i].ID>>stu[i].C>>stu[i].M>>stu[i].E;
		stu[i].A = (double)(stu[i].C + stu[i].M + stu[i].E) / 3;
	}
	for (int i=0; i<N; i++) cin>>stu_ID[i];

	sort(stu, stu+M, cmp_C);//对C排序,排序后对这门科目排序,相同分数排名相同,下同
	for (int i=0; i<M; i++)
	{
		if (i == 0) stu[0].C_rank = 1; 
		else if (stu[i].C == stu[i-1].C) stu[i].C_rank = stu[i-1].C_rank;
		else stu[i].C_rank = i+1;
	}		
	sort(stu, stu+M, cmp_M);
	for (int i=0; i<M; i++)
	{
		if (i == 0) stu[0].M_rank = 1; 
		else if (stu[i].M == stu[i-1].M) stu[i].M_rank = stu[i-1].M_rank;
		else stu[i].M_rank = i+1;
	}
	sort(stu, stu+M, cmp_E);
	for (int i=0; i<M; i++)
	{
		if (i == 0) stu[0].E_rank = 1; 
		else if (stu[i].E == stu[i-1].E) stu[i].E_rank = stu[i-1].E_rank;
		else stu[i].E_rank = i+1;
	}
	sort(stu, stu+M, cmp_A);
	for (int i=0; i<M; i++)
	{
		if (i == 0) stu[0].A_rank = 1; 
		else if (stu[i].A == stu[i-1].A) stu[i].A_rank = stu[i-1].A_rank;
		else stu[i].A_rank = i+1;
	}
	for (int i=0; i<N; i++)//输出ACME的priority规则下的最高排名
	{
		for (int j=0; j<M; j++)
		{
			if(stu_ID[i] == stu[j].ID)
			{
				int max_rank = stu[j].A_rank; 
				char max_rank_kemu = 'A';
				if (max_rank > stu[j].C_rank)
				{
					max_rank = stu[j].C_rank;
					max_rank_kemu = 'C';
				}
				if (max_rank > stu[j].M_rank)
				{
					max_rank = stu[j].M_rank;
					max_rank_kemu = 'M';
				}
				if (max_rank > stu[j].E_rank)
				{
					max_rank = stu[j].E_rank;
					max_rank_kemu = 'E';
				}
				cout<<max_rank<<" "<<max_rank_kemu<<endl;
				break;
			}
			if(j == M-1) cout<<"N/A"<<endl;
		}
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值