TOJ 3259.Mysterious Number(埃式筛法)

题目链接:http://acm.tju.edu.cn/toj/showp3259.html



3259.    Mysterious Number
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 1356    Accepted Runs: 435



Mysterious Number refers to a number which can be divisible by the number of distinct factors that it has. For instance, 1 (1 factor), 12 (6 factors) and 9 (3 factors) are Mysterious Numbers, but 7(2 factors) or 16 (5 factors) are not.

Given two integers low and high, please calculate the number of Mysterious Numbers between low and high, inclusive.

Input

For each test case, there are two integers  low and  high in one line separated by spaces. 1 ≤  low ≤  high ≤ 1,000,000

Output

Print out the number of Mysterious Numbers between  low and  high, inclusive.

Sample Input

1 10
10 15

Sample Output

4
1

Author: WTommy



Source: TJU Team Selection Contest 2009 (4)
Submit   List    Runs   Forum   Statistics

Tianjin University Online Judge  v1.3.0
Maintance: G.D.Retop. Developer:  SuperHackerG.D.Retop



题意很好理解,所谓神秘数就是指一个数是否能够被它的约数整除。然后我就傻乎乎的枚举暴力来了一波,果不其然——超时。随后学习了一下大神的帖子,知道了一种算法叫:埃式筛法,关于埃式筛法具体的内容见博客:


#include <stdio.h>
#include <algorithm>
using namespace std;
const int MAX = 1000000+2;  
int fac[MAX] = {0,1}; 

int main(){
	int low,high,sum;
	fill(fac+2,fac+MAX,2);
	for (int i = 2; i < (MAX>>1); ++i)  
        for (int j = 2; i * j < MAX; ++j) {  
            ++fac[i*j];  
        }
	while(~scanf("%d%d",&low,&high)){
		sum=0;
		for(int i=low;i<=high;i++)
			if(i%fac[i]==0)
				sum++;
		printf("%d\n",sum);
	}
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值