TOJ 3496.Summation

题目链接:http://acm.tju.edu.cn/toj/showp3496.html


3496.    Summation
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 1847    Accepted Runs: 581



CXB join an interview, the interviewer give him a problem. He is asked to reverse every number and calculate the summation of the new number. For instance, there are two numbers 10 and 14, the answer after reverse is 1 and 41, so the final answer is 1+41=42.

Input

The first line of the input contains n.(n<=100000).The following n lines. Each line contains two integer numbers x and y .(0<=x, y<=100000).

Output

Write to the output a single number. Terminate with a blank line.

Sample Input

2
1 1
21 20

Sample Output

2

14



Source: TJRAC Team Selection 2010 (1)
Submit   List    Runs   Forum   Statistics


水题,把两个数的分别跌倒顺序后相加:


#include <stdio.h>
#include <cmath>
using namespace std;
int reserve(int n){
	int tmp=n,i,num;
	for(i=1;(tmp/10)!=0;i++)
		tmp/=10;
	num=0;
	//printf("%d\n",i);
	while(i--){
		int p=n%10;
		n/=10;
		num+=((int)(p*pow(10,i*1.0)));
	}
	return num;
} 
int main(){
	int n,x,y;
	scanf("%d",&n);
	while(n--){
		scanf("%d%d",&x,&y);
		printf("%d\n\n",reserve(x)+reserve(y));
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值