TOJ 2867.Picking Problem(最大区间调度)

题目链接:http://acm.tju.edu.cn/toj/showp2762.html


2867.    Picking Problem
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 1969    Accepted Runs: 831



On holiday, Kandy happens to come to a square. People there are playing different kinds of games. Each game has a start time and a lasting duration. Two or more games may carry on at the same time. Kandy likes the games so much that he wants to take apart in as many as possible games. Given the list of all the games, can you help him to calculate the maximum number of games that he can take.

Input

There are several test cases. The first line of each test case is a single integer  N, which is the total number of the games (1 ≤  N ≤ 10000). It's followed by  N lines, each line has two integers,  S and  D, and  S is the start time of the  ith game, and  D is the game's duration (0 ≤  S ≤ 10000, 1 ≤  D ≤ 1000).

The last case is followed by a single integer 0.

Output

For each case, output one line with a single integer  M, which is the maximum number of games that Kandy can take.

Sample Input

5
0 3
5 10
9 2
3 4
2 2
0

Sample Output

3

Hint: In the sample, the first game starts at 0, ends at 3, and the forth game starts at 3, ends at 7, and the third game starts at 9, ends at 11. So he can pick these three games.



Source: TJU Team Selection Contest 2007 (3)
Submit   List    Runs   Forum   Statistics


题目大意:给定一系列活动的开始时间和结束时间,问最多能参加的活动数目

思路:// 本题属于最大区间调度问题,即数轴上有n个区间,选出最多的区间,使这些区间互相不重叠。算法:按右端点坐标排序,然后依次按后者的开始时间是否大于前者的结束时间(注意更新前者的下标)选择所有能选的区间。


#include <stdio.h>
#include <algorithm>
using namespace std;
struct game{
	int s,e;
};
bool com(game a,game b){
	return a.e<b.e;
}
int main(){
	game games[10001];
	int n,dur;
	while(~scanf("%d",&n),n){
		for(int i=0;i<n;i++){
			scanf("%d%d",&games[i].s,&dur);
			games[i].e=games[i].s+dur;
		}
		sort(games,games+n,com);
		int m=0,sum=1;
		for(int i=1;i<n;i++)
			if(games[i].s>=games[m].e){
				sum++;
				m=i;
			}
	printf("%d\n",sum);
	}
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值