TOJ 2577.Rounders

题目链接:http://acm.tju.edu.cn/toj/showp2577.html


2577.    Rounders
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 1203    Accepted Runs: 789



Introduction:

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand, and so on ...

Input:

Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 ≤ x ≤ 99999999).

Output:

For each integer in the input, display the rounded integer on its own line.

Note: Round up on fives.

Sample Input:

9
15
14
4
5
99
12345678
44444445
1445
446

Sample Output:

20
10
4
5
100
10000000
50000000
2000
500


Source: South Central USA 2006
Submit   List    Runs   Forum   Statistics

水题,过之:

#include <stdio.h>
using namespace std;
int main(){
	int n,num;
	scanf("%d",&num);
	while(num--){
		int l,m;
		scanf("%d",&n);
		if(n<=10)
			printf("%d\n",n);
		else{
			for(l=0;(n/10)!=0;l++){
				int tmp=n;
				n/=10;
				if(tmp%10>=5)
					n++;
			}
			printf("%d",n);
			for(int i=0;i<l;i++)
				printf("0");
			printf("\n");
		}
	}
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值