杭电 Identity Card

Identity Card

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1969 Accepted Submission(s): 627
 
Problem Description
Do you own an ID card?You must have a identity card number in your family's Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it.
Here is the codes which represent the region you are in.

However,in your card,maybe only 33 appears,0000 is replaced by other numbers.
Here is Samuel's ID number 331004198910120036 can you tell where he is from?The first 2 numbers tell that he is from Zhengjiang Province,number 19891012 is his birthday date (yy/mm/dd).
Input
Input will contain 2 parts:
A number n in the first line,n here means there is n test cases. For each of the test cases,there is a string of the ID card number.
Output
Based on the table output where he is from and when is his birthday. The format you can refer to the Sample Output.
Sample Input
1
330000198910120036
Sample Output
He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.
Author
Samuel
Source
灰色橙子 专场
Recommend
zty
 
 
代码:

#include <iostream>
#include <string>
using namespace std;

int main()
{
 int n;
 double temp;
 string place;
 char st[18];

 cin >> n;
 getchar();                                 //getchar()来吃掉enter,要不然enter会被gets函数读入
 while (n--)
 {
  gets(st);
  cout << "He/She is from ";
  if (st[0] == '3' && st[1] == '3')     //3要用''括起来,因为st是字符数组
   cout << "Zhejiang";
  else if (st[0] == '1' && st[1] == '1')
   cout << "Beijing";
  else if (st[0] == '7' && st[1] == '1')
   cout << "Taiwan";
  else if (st[0] == '8' && st[1] == '1')
   cout << "Hong Kong";
  else if (st[0] == '8' && st[1] == '2')
   cout << "Macao";
  else if (st[0] == '5' && st[1] == '4')
   cout << "Tibet";
  else if (st[0] == '2' && st[1] == '1')
   cout << "Liaoning";
  else if (st[0] == '3' && st[1] == '1')
   cout << "Shanghai";

  cout << ",and his/her birthday is on "
    << st[10] << st[11] << ','
    << st[12] << st[13] << ','
    << st[6] << st[7] << st[8] << st[9];
  cout << " based on the table."
    << endl;
 }

 return 0;
}

 

总结:

一开始想用 int temp来存放ID Card Number,运用'/'和'%'来提取号码,但是没那么大的整形变量,
而用double的话,不能用'%',而且会发生溢出错误。
所以运用了字符数组。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值