hdu1865大数 1sting


1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3117    Accepted Submission(s): 1194


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2 8
 

分析:

    简单递推+大数。
    ans[n]=ans[n-1]+ans[n-2]。
    由于数字只有'1'和'2'这两种,那么当让第n
位为1的时候,ans[n]加上ans[n-1];当让最后两位
合并成2的时候,ans[n]加上ans[n-2](因为要保证
倒数第二位一定是1)。

    算出来的ans就是一个斐波那契数列。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=205;
int a[N][N];
char s[N];
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>s;
        int i,j,d;
        d=strlen(s);
        for(i=0;i<=d;i++)
            for(j=0;j<=d;j++)
                a[i][j]=0;
        a[0][0]=0;a[1][0]=1;a[2][0]=2;
        for(i=3;i<=d;i++)
        {
           int c=0,ss;
           for(j=0;j<d;j++)
           {
               ss=a[i-1][j]+a[i-2][j]+c;
               c=ss/10;
               a[i][j]=ss%10;
           }
        }
        int k=N-1;
        while(k--) 
            if(a[d][k]) 
            break;
        for(i=k;i>=0;i--)
            cout<<a[d][i];
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值