hdu 5178

pairs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1056    Accepted Submission(s): 372


Problem Description
John has  n  points on the X axis, and their coordinates are  (x[i],0),(i=0,1,2,,n1) . He wants to know how many pairs <a,b>  that  |x[b]x[a]|k.(a<b)
 

Input
The first line contains a single integer  T  (about 5), indicating the number of cases.
Each test case begins with two integers  n,k(1n100000,1k109) .
Next  n  lines contain an integer  x[i](109x[i]109) , means the X coordinates.
 

Output
For each case, output an integer means how many pairs <a,b>  that  |x[b]x[a]|k .
 

Sample Input
  
  
2 5 5 -100 0 100 101 102 5 300 -100 0 100 101 102
 

Sample Output
  
  
3 10
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5182  5181  5180  5179  5178 
 
直接二分,时间复杂度nlog(n)

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;
#define ll long long
ll x[100010];
int main(){
    int T; scanf("%d",&T);
    while(T--){
        int n,k;
        scanf("%d%d",&n,&k);
        for(int i=0;i<n;i++){
            scanf("%I64d",&x[i]);
        }
        sort(x,x+n);
        ll sum=0;
        for(int i=0;i<n-1;i++){
            int left=i+1;
            int right=n-1;
            int mid=(left+right)>>1;
            while(1){
                int t_mid=mid;
                if(x[mid]-x[i]>k){
                    right=mid-1;
                }
                else if(x[mid]-x[i]<k){
                    left=mid+1;
                }
                else{
                    break;
                }
                mid=(left+right)>>1;
                if(t_mid==mid){
                    break;
                }
            }
            if(x[mid]-x[i]<=k){
                sum+=(ll)mid-i;
            }
        }
        printf("%I64d\n",sum);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值