2017中国大学生程序设计竞赛 - 网络选拔赛 && HDU 6156 Palindrome Function 【数位DP】

Palindrome Function

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit:256000/256000 K (Java/Others)
Total Submission(s): 713    Accepted Submission(s): 383

Problem Description

As we all know,a palindrome number is the number which reads the same backward as forward,such as 666 or 747.Some numbers are not the palindrome numbers in decimal form,but in other base,they may become the palindrome number.Like 288,it’s not a palindrome number under 10-base.But if we convert it to 17-base number,it’s GG,which becomes a palindrome number.So we define an interesting function f(n,k) as follow:
f(n,k)=k if n is a palindrome number under k-base.
Otherwise f(n,k)=1.
Now given you 4 integers L,R,l,r,you need to caluclate the mathematics expression 
Ri=Lrj=lf(i,j) .
When representing the k-base(k>10) number,we need to use A to represent 10,Bto represent 11,C to repesent 12 and so on.The biggest number is Z(35),so we only discuss about the situation at most 36-base number.

 

 

Input

The first line consists of an integer T,which denotes the number of test cases.
In the following T lines,each line consists of 4 integers L,R,l,r.
(1≤
T≤105,1≤LR≤109,2≤lr≤36)

 

 

Output

For each test case, output the answer in the form of “Case #i: ans” in a seperate line.

 

 

Sample Input

3

1 1 2 36

1 982180 10 10

496690841 524639270 5 20

 

 

Sample Output

Case #1: 665

Case #2: 1000000

Case #3: 447525746

 


【题意】

定义f(n,k),当n在k进制下为回文数时,f(n,k)为k,否则为1。

【思路】


用dp[i][j][k][1]表示k进制下长度为i枚举到了第j位时的回文数数量。


用dp[i][j][k][0]表示k进制下长度为i枚举到了第j位时的非回文数数量


然后就按照数位DP的固定格式写就好了。


【PS】这题用G++提交能节省一半的时间,C++提交易超时!!!



#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define mst(a,b) memset((a),(b),sizeof(a))
#define rush() int T;scanf("%d",&T);while(T--)

typedef long long ll;
const int maxn = 35;
const ll mod = 1e9+7;
const int INF = 0x3f3f3f;
const double eps = 1e-9;

ll bit[maxn];
ll temp[maxn];
ll dp[maxn][maxn][40][2];  //dp[i][j][k][1]表示k进制下长度为i枚举到了第j位时的回文数数量

ll dfs(ll len,ll cur,ll base,ll limit,ll st)
{
    if(cur<0) return st;
    if(limit==0&&~dp[len][cur][base][st])
        return dp[len][cur][base][st];
    int up=limit?bit[cur]:base-1;
    ll ans=0;
    for(int i=0;i<=up;i++)
    {
        temp[cur]=i;
        if(len==cur&&i==0)
        {
            ans=ans+dfs(len-1,cur-1,base,limit&&i==up,st);
        }
        else if(cur<(len+1)/2&&st)
        {
            ans=ans+dfs(len,cur-1,base,limit&&i==up,temp[len-cur]==i);
        }
        else
        {
            ans=ans+dfs(len,cur-1,base,limit&&i==up,st);
        }
    }
    return limit?ans:dp[len][cur][base][st]=ans;
}

ll solve(ll x,ll base)
{
    int len=0;
    while(x)
    {
        bit[len++]=x%base;
        x/=base;
    }
    mst(temp,-1);
    return dfs(len-1,len-1,base,1,1);
}

int main()
{
    ll L,R,l,r;
    mst(dp,-1);
    int cas=1;
    rush()
    {
        scanf("%I64d%I64d%I64d%I64d",&L,&R,&l,&r);
        ll ans=0;
        for(int i=l;i<=r;i++)
        {
            ll cnt=solve(R,i)-solve(L-1,i);    //k进制时区间内回文数个数
            ans+=cnt*i+(R-L+1-cnt);
        }
        printf("Case #%d: %I64d\n",cas++,ans);
    }
    return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值