低版本Xcode在没有最新DeviceSupport文件时如何调试真机

在这里插入图片描述



问题现象

大家知道,一般来说低版本Xcode是无法去调试高版本真机设备的。

我们通常采用的做法是下载最新的iOS DeviceSupport文件,放入Xcode的对应目录中。

但是如果找不到最新的DeviceSupport文件怎么办?



问题分析

问题原因很简单,就是缺少对应版本的真机调试支持文件。

一般是从网上下载或者从最新的Xcode中拷贝该文件,但是如果由于新版本推出时间很短,网上还下载不到,或者你又不想下载7、8GB的XCode,又该如何呢?

举个栗子,本篇写作时iOS 13.5.1(17F80)放出才不久,网上是找不到该版本的调试支持文件的。

我开发的本本是12年的MBA,存储只有128GB,几乎已经撑满了,无法下载最新的Xcode,更别说下载后再解压缩了。

我的Xcode 版本是11.3.1,Mac系统版本是Mojave 10.14.6,所以Xcode版本也无法再更新了。

我的真机升级到13.5.1后,用Xcode调试提示当前版本的Xcode无法支持调试13.5.1版本的设备,提示类似如下内容:

大熊猫侯佩 CSDN认证博客专家 Swift Objective-C Xcode
非自由程序员,CSDN博客认证专家。
CSDN汇编板块版主, CSDN其他开发语言大版版主。

对App、以及Cocos2D、SpriteKit游戏开饶有兴趣。目前常用的语言是ObjC、Swift、Ruby等。不过看到编程艺术、ASM、逆向和C时依然欲罢不能。虽然不是,但喜欢黑客的思维和哲学,认为社会工程学很酷,但还没有实际用来撩过妹。
©️2020 CSDN 皮肤主题: 精致技术 设计师:CSDN官方博客 返回首页
实付 39.90元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值