F - Power Strings POJ - 2406 mystical_curve

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.



这个题对我来说很好的一个题,主要是有一个样列十分巧的卡到了我的算法,
看过有人给出的忍不住就想写分博客。题意给定一个字符串,有一个*定义
为字符串的连接。求出给定的字符串中最大的是有多少个相同的字符串连接而
成的。

解题思路:这个题很容易就想到与kmp有关,然后想过后发现kmp遍历一遍过

后可以求出一个最小的字符串的长度,及c=s.size()-nex[s.size()].然后简单验证过

后发现前nex[s.size()]整体向右移动c位后边是前c*n个,因此可以判断了此法的正确性。然后只需在遍历一遍看看前c个连接后是否相等即可。但是有一组样列卡到了这种算法aabaabaa,这个也是我写这个题的主要原因。

#include <iostream>
#include <cstring>
#include <vector>
#include <cstdio>
#include <cmath>
#include <map>
#include <stack>
#include <algorithm>
#define pb push_back
#define mk make_pair
typedef long long ll;
using namespace std;
const int inf = 1e6+100;
string s;
int nex[inf];
int fun()
{
    int c=-1,d=0;
    nex[0]=-1;
    while(d<s.size())
    {
        if(c==-1||s[d]==s[c])
        {
            c++;d++;
            nex[d]=c;
        }
        else
        c=nex[c];
    }
    int x;
    if(s[nex[c]]==s[s.size()-1])x=s.size();
    else x=s.size();
    return x-nex[s.size()];
}
bool check(int k)
{
    bool f=true;int i;
    for( i=k;i<s.size();i++)
    {
        if(s[i-k]!=s[i]){
            f=false;break;
        }
    }
    if(i%k)f=false;
    return f;
}
int main()
{
    while(getline(cin,s),s!=".")
    {
         int c=fun();
         //cout<<c<<endl;
        if(check(c)){
            printf("%d\n",s.size()/c);
        }else
        {
            printf("1\n");
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值