G - Power Strings POJ 2406 (字符串的周期)


G - Power Strings
Time Limit:3000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 2406

Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output
For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

1.直接暴力枚举


#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<vector>
using namespace std;
const int maxn=1000005;
typedef long long LL;
char s[maxn];
int main(){
    int T;
    //freopen("Text//in.txt","r",stdin);
    while(~scanf("%s",s)&&s[0]!='.'){
        int len=strlen(s);
        for(int i=1;i<=len;i++)if(len%i==0){
            int ok=1;
            for(int j=i;j<len;j++){
                if(s[j]!=s[j%i]){
                    ok=0;break;
                }
            }
            if(ok){
                printf("%d\n",len/i);break;
            }
        }
    }
    return 0;
}



2.kmp算法 i-next[i]:表示已i结尾的前缀的循环节的长度


#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<vector>
using namespace std;
const int maxn=1000005;
typedef long long LL;
char s[maxn];
int next[maxn];
void getnext(char*s){
    int len=strlen(s);
    int i=0,j=-1;
    next[0]=-1;
    while(i<len){
        if(j==-1||s[i]==s[j]){
             next[++i]=++j;
        }
        else
            j=next[j];
    }
}
int main(){
    int T;
    //freopen("Text//in.txt","r",stdin);
    while(~scanf("%s",s)&&s[0]!='.'){
        int len=strlen(s);
        getnext(s);
        int k=len-next[len];
        if(len%k==0){
            printf("%d\n",len/k);
        }
        else
            printf("1\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值