Trailing Zeroes (III)


You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

#include <cstdio>  
#define MAX 0x7fffffff      //最大的 long int型数   
int cal(int n)      //计算n的阶乘后0的个数  
{  
    int ans = 0;  
    while (n)  
    {  
        ans += n/5;  
        n /= 5;  
    }  
    return ans;  
}  
int main()  
{  
    int u;  
    int n;  
    scanf ("%d",&u);  
    int num = 1;  
    while (u--)  
    {  
        scanf ("%d",&n);  
        printf ("Case %d: ",num++);  
        int left = 0,right = MAX;  
        int mid;  
        while (left <= right)  
        {  
            mid = (left + right)>>1;      //就是(left + right)/2的意思  
            if (cal(mid) >= n)  
                right = mid - 1;  
            else  
                left = mid +1;  
        }  
        if (cal(left) == n)     //若最后一次逼近的时候满足了条件,此时left==mid(无论left与right相差1还是相等)   
            printf ("%d\n",left);  
        else  
            printf ("impossible\n");  
    }  
    return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值