1101 Quick Sort (25 分)

36 篇文章 1 订阅

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

解释:

背景是快速排序,在完成一趟快速排序(升序)之后,中枢数字左边的数都小于它,右边的数都大于他,现在给你一串序,问可能是中枢数字的是那些

#include<stdio.h>
#include<algorithm>
using namespace std;
const int MAX=100010;
//max_num[i],0-i为最大的数字,
//min_num[i],记录i-n-1,最小的数
int num[MAX],min_num[MAX],max_num[MAX],result[MAX];
int main()
{
    int N,k=0;
    scanf("%d",&N);
    for(int i=0;i<N;i++)
    {
        //输入数组
        scanf("%d",&num[i]);
        //找截止到i的最大的的数
        //要想大于左边所以数,只需要大于左边最大的数就行
        if(i==0) 
            max_num[i]=num[i];
        else
        {
            if(num[i]>max_num[i-1])
                max_num[i]=num[i];
            else
                max_num[i]=max_num[i-1];
        }
    }
    //从右往左找,找到i-n-1最小的数
    //小于右边,即小于右边的最小值
    for(int i=N-1;i>=0;i--)
    {
        if(i==N-1) 
            min_num[i]=num[i];
        else
        {
            if(num[i]<min_num[i+1])
                min_num[i]=num[i];
            else
                min_num[i]=min_num[i+1];
        }
        //找到中枢数
        //算上中枢,中枢是左边最大的,是右边最小的
        if(num[i]==min_num[i]&&num[i]==max_num[i])
            result[k++]=num[i];
    }
    //排序完输出
    sort(result,result+k);
    printf("%d\n",k);
    for(int i=0;i<k;i++)
    {
        if(i==0)
            printf("%d",result[i]);
        else
            printf(" %d",result[i]);
    }
    printf("\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值