1079 Total Sales of Supply Chain (25 分)

36 篇文章 1 订阅

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤ 1 0 5 10^5 105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K i I D [ 1 ] I D [ 2 ] . . . I D [ K i ] K_i ID[1] ID[2] ... ID[K_i] KiID[1]ID[2]...ID[Ki]

where in the i-th line, K i K_i Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K j K_j Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K j K_j Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed$ 10^{10}$.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

解释:

这题用树做

供应商理解为根节点,经销商是非叶子节点而零售商就是叶子结点。

第一行输入 结点个数(包括根节点)N,供应商的售价p,和每经过一个经销商商的涨幅r(%)

接下来N行代表从0-N-1每个结点的孩子情况0号代表根节点。

每行先输入孩子个数,如果为零,就是叶子结点,此时输入这个零售商有多少货。如果非零,就输入孩子结点的序号。

这里的孩子数不固定可以用vector存放。

#include<cstdio>
#include<iostream>
#include<vector>
#include<math.h>
using namespace std;
const int maxn=100010;
int n;
double p, r,result=0;
struct node
{
    double data;//数据域
    vector<int> children;
}Node[maxn];
void DFS(int index,int depth)
{
    if(Node[index].children.size()==0)
    {//叶子结点,货物数量乘增长值
        result+=Node[index].data*pow(1+r,depth);
        return;
    }
    for(int i=0;i<Node[index].children.size();i++)
        DFS(Node[index].children[i],depth+1);
}
int main()
{
    cin>>n>>p>>r;
    r=r/100.0;
    for(int i=0;i<n;i++)
    {
        int k,node_temp;
        double temp;
        cin>>k;
        //叶子结点
        if(k==0)
        {
            cin>>temp;
            Node[i].data=temp;
        }
        //非叶子结点
        else
        {
            for(int j=0;j<k;j++)//读入孩子结点
            {
                cin>>node_temp;
                Node[i].children.push_back(node_temp);
            }
        }
    }
    DFS(0,0);
    //结果还要乘一开始的成本价格
    printf("%.1lf",p*result);
    return 0;
}
/*
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3
*/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值