1090 Highest Price in Supply Chain (25 分)

36 篇文章 1 订阅

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N ( ≤ 1 0 5 ≤10^5 105), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S i S_i Si is the index of the supplier for the i-th member. S r o o t S_{root} Sroot for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1 0 10 10^{10} 1010.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

解释:

这题用树做

供应商理解为根节点,经销商是非叶子节点而零售商就是叶子结点。

第一行输入 结点个数(包括根节点)N,供应商的售价p,和每经过一个经销商商的涨幅r(%)

第二行输入N个结点的发父结点序号,root的负结点为-1

输出:

零售商的最大价格,以及有多少个这个的零售商

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<vector>
using namespace std;
const int maxn=100010;
vector<int> child[maxn];//存i结点的孩子的
double p,r;
int n,maxdepth=0,num=0;
void DFS(int index,int depth)
{
    if(child[index].size()==0)//叶子结点
    {
        if(depth>maxdepth)//深度更大的叶子结点
        {
            maxdepth=depth;
            num=1;
        }
        else if(depth==maxdepth)//深度一样大的叶子结点
            num++;
        return;
    }
    for(int i=00;i<child[index].size();i++)
        DFS(child[index][i],depth+1);
}
int main()
{
    int father,root;
    cin>>n>>p>>r;
    r/=100;
    for(int i=0;i<n;i++)
    {
        cin>>father;
        if(father!=-1)
            child[father].push_back(i);//father的结点是i
        else
            root=i;
    }
    DFS(root,0);
    printf("%.2f %d",p*pow(1+r,maxdepth),num);
    return 0;
}


/*
9 1.80 1.00
1 5 4 4 -1 4 5 3 6

1.85 2
*/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值