hpu18级0728(二分+尺取练习) Trailing Zeroes (III)

E - Trailing Zeroes (III)

 https://vjudge.net/contest/241732#problem/E

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

题意:给个n,让你找哪个数的阶乘末尾有n个0

二分法加上判断谁的阶乘后面有n个0这个函数,如何求谁的阶乘后面有n个0好像是数学上一个固定的知识点,可以搜一搜

代码:

#include <stdio.h>
#include <iostream>
using namespace std; 
int zero(int x)
{
	int count=0;
	while(x)
	{
		count=count+x/5;
		x=x/5;
	}
	return count;
}
int find(int q)
{
	long long left=0,right=1000000000000,mid;
	while(left<=right)
	{
		mid=(left+right)>>1;
		if(zero(mid)>=q)
		right=mid-1;
		else
		left=mid+1;
	}
	if(zero(left)==q)
	printf("%d\n",left);
	else
	printf("impossible\n");
	return 0;
}
int main()
{
	int t,k=0;
	cin>>t;
	while(t--)
	{
		k++;
		int q;
		cin>>q;
		printf("Case %d: ",k);
		find(q);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值