Codeup贪心:To Fill or Not to Fill

题目描述

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

输入

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg(<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

输出

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

样例输入

59 525 19 2
3.00 314
3.00 0

样例输出

82.89

提示

该题目所要解决的问题是:给定若干加油站信息,问能否驾驶汽车行驶一定的距离。如果能够行驶完全程,则计算最小花费。若不能行驶完全程,则最远能够行驶多长距离。

拿到这一题,首先判断汽车是否能够行驶到终点。什么情况下汽车无法行驶到终点呢?

两种情况起点根本就没有加油站,汽车无法启动;或者中途两个加油站之间的距离大于加满油后汽车能够行驶的最大距离。前者汽车行驶的最大距离为0.00,而后者最大距离为当前加油站的距离加上在这个加油站加满油后能够行驶的最大距离。在这里,需要将加油站按到杭州的距离从小到大排序。

接下来在能够行驶到终点的情况下计算最小花费。我们首先从路程来考虑,如果在路上,我们能够使用最便宜的汽油,当然就在那个加油站加油了。所以从起点开始遍历每个加油站。假设遍历到了第i个加油站,我们现在来判断在加油站i应该加多少油。设当前汽车离杭州的距离为curLen,当前加油站离杭州的距离为nodes[i].dis,加满油以后汽车能够行驶的最大距离为(dis=cmax*len)。这样就有node[i].dis <= curLen <= nodes[i].dis+dis,否则的话第i个加油站的油是不起作用的。于是在第i个加油站的作用范围内寻找有没有更为便宜的加油站,如果有,则下次使用这个加油站的油(j),这次汽车应该行驶到这个加油站,即touch=nodes[j].dis。如果没有找到更为便宜的加油站则可以在第i个加油站加满油,即touch=nodes[i].dis+dis。然后判断下次应该行驶到的距离与当前距离的关系,如果下次应当行驶到的距离大于当前距离,则汽车行驶,否则不动(也就是说上个加油站的油更便宜,后一个加油站也便宜,根本就不需要在当前加油站加油)。


91分答案 

#include<bits/stdc++.h>
using namespace std;
const int MAX=505;
double cmax,D,len;
int N;
struct Node{
	double p;
	double dis;
}nodes[MAX];
bool cmp(Node a, Node b){
	return a.dis<b.dis;
}
int main(){
	double cnt=0;
	scanf("%lf%lf%lf%d",&cmax,&D,&len,&N);
	double mdis=cmax*len;
	for(int i=0;i<N;i++){
		scanf("%lf%lf",&nodes[i].p,&nodes[i].dis);
	}
	sort(nodes,nodes+N,cmp);
	nodes[N-1].dis=D;
	nodes[N-1].p=0;
	if(D==0){
		printf("0.00\n");
		return 0;
	} 
	if(nodes[0].dis!=0) {//起点没有加油站 
		printf("The maximum travel distance = 0.00\n");
		return 0;
	}

	for(int i=1;i<N;i++){//加油站之间的距离大于最大行驶距离mdis 
		if(nodes[i].dis-nodes[i-1].dis>mdis){
			printf("The maximum travel distance = %.2lf\n",nodes[i-1].dis+mdis);  
			return 0;
		}
	}

	int curLen=0,i;
	double spd=0,gas=0;
	while(curLen<=N){
		if(nodes[curLen].dis+mdis>=D){//从当前点能到达目的地 
			for(i=curLen+1;i<N;i++){
				if(nodes[i].p<nodes[curLen].p){//有更便宜的加油站 
					spd+=(nodes[curLen].p*((nodes[i].dis-nodes[curLen].dis)/len-gas));
					curLen=i;gas=0;
					break;
				}
			}
			if(i==N){//没有更便宜的 
			 spd+= (nodes[curLen].p*((D-nodes[curLen].dis)/len-gas));
			 break;
			}
		}
		else{//从当前点到达不了目的地 
			int flag=true;
			for(i=curLen+1;nodes[i].dis<(nodes[curLen].dis+mdis);i++){
				if(nodes[i].p<nodes[curLen].p){
					flag=false;
					spd+=(nodes[curLen].p*((nodes[i].dis-nodes[curLen].dis)/len-gas));
					gas=0;curLen=i;
					break;
					}
			}
			if(flag==true){//没有更便宜的加油站 ,在可达范围内找最便宜的
				double minp=nodes[curLen+1].p;
				int j,index;
				for(j=curLen+1;nodes[j].dis<(nodes[curLen].dis+mdis);j++){
				 	if(minp>=nodes[j].p){
						minp=nodes[j].p;
						index=j;
					}
				}
				spd+=(nodes[curLen].p*(cmax-gas));
				gas=cmax-(nodes[index].dis-nodes[curLen].dis)/len;
				curLen=index;
			}
		}
	}
	printf("%.2lf\n",spd);
	return 0;
}
	
	

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值