hdu 3652 B-number(数位dp)

B-number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7199 Accepted Submission(s): 4216

Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string “13” and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output
Print each answer in a single line.

Sample Input
13
100
200
1000

Sample Output
1
1
2
2

dp[pos][pre][stat][r][limit];
pos :当前位;
pre:当前位的前一位
stat:是否满足存在一个“13”字串
limit:是否存在前一位的限制

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <set>
#include <map>
#include <queue>
#include <cmath>
#include <cstring>
#include <string>
using namespace std;
int dp[10][10][2][13][2];
int a[10];
int dfs(int pos,int pre,int stat,int r,int limit){
    if (pos==-1) return ((r==0)&&stat);
    if (!limit&&dp[pos][pre][stat][r][limit]!=-1) return dp[pos][pre][stat][r][limit];
    int up=limit?a[pos]:9;
    int ans=0;
    for (int i=0;i<=up;i++){
        if (pre==1&&i==3) ans+=dfs(pos-1,i,1,(r*10+i)%13,limit&&i==a[pos]);
        else ans+=dfs(pos-1,i,stat,(r*10+i)%13,limit&&i==a[pos]);  
    }
    if (!limit) dp[pos][pre][stat][r][limit]=ans;
    return ans;

}
int solve(int x){
    int pos=0;
    while (x){
        a[pos++]=x%10;
        x/=10;
    }
    return dfs(pos-1,0,0,0,1);
}
int main()
{   
    int n;
    memset(dp,-1,sizeof(dp));
    while (~scanf("%d",&n)){
        printf("%d\n",solve(n));
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值