A Simple Problem with Integers POJ - 3468

A Simple Problem with Integers POJ - 3468
整理一下之前刷过的题
You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
**题意:**简单的区间加与查询操作
线段树模板题,算做记模板
代码:

#include<stdio.h>
#include<istream>
#include<map>
#define ll long long
using namespace std;
const int maxn=1e5+7;
const int INF=1e9+7;
inline ll read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
ll sum[maxn<<2];
ll add[maxn<<2];
void pushdown(ll root,ll k)
{
    if(add[root])
    {
        add[root<<1]+=add[root];
        add[root<<1|1]+=add[root];
        sum[root<<1]+=(k-(k>>1))*add[root];
        sum[root<<1|1]+=(k>>1)*add[root];
        add[root]=0;
    }
}
void build(ll root,ll l,ll r)
{
    add[root]=0;
    if(l==r)
    {
        scanf("%lld",&sum[root]);
        return;
    }
    ll mid=(l+r)>>1;
    build(root<<1,l,mid);
    build(root<<1|1,mid+1,r);
    sum[root]=sum[root<<1]+sum[root<<1|1];
}

void change(ll root,ll l,ll r,ll ql,ll qr,ll k)
{
    if(ql<=l&&qr>=r)
    {
        sum[root]+=k*(r-l+1);
        add[root]+=k;
        return;
    }
    ll mid=(l+r)>>1;
    pushdown(root,r-l+1);
    if(ql<=mid) change(root<<1,l,mid,ql,qr,k);
    if(qr>mid)  change(root<<1|1,mid+1,r,ql,qr,k);
    sum[root]=sum[root<<1]+sum[root<<1|1];
}
ll q(ll root,ll l,ll r,ll ql,ll qr)
{
    if(ql<=l&&qr>=r)
    {
        return sum[root];
    }
    ll mid=(l+r)>>1;
    pushdown(root,r-l+1);
    ll ans=0;
    if(ql<=mid) ans+=q(root<<1,l,mid,ql,qr);
    if(qr>mid)  ans+=q(root<<1|1,mid+1,r,ql,qr);
    return ans;
}
int main()
{
    ll n,m;
    n=read();m=read();
    build(1,1,n);
    //printf("hah\n");
    while(m--)
    {
        //getchar();
        char s[3];
        scanf("%s",s);
        if(s[0]=='Q')
        {
            ll x=read(),y=read();
            //scanf("%lld%lld",&x,&y);
            ll ans=q(1,1,n,x,y);
            printf("%lld\n",ans);
        }
        else if(s[0]=='C')
        {
            ll x=read(),y=read(),k=read();
            //scanf("%lld%lld%lld",&x,&y,&k);
            change(1,1,n,x,y,k);
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值