uvaoj-10815:安迪的第一个字典

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

 

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

 

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

 

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

 

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

 

题解:来自刘汝佳112页set的例题。做这个题的方法也是刘汝佳的方法,这次先做笔记,后贴代码,因为和ac比起来,得到的教训才是更重要的吧;

笔记:迭代器在c++中相当于指针;set集合中的元素是自动有序排列的,用时也是唯一的;迭代器中大部分都没有“<”或“>”运算符;string,vector,set,map的确比传统c更加方便,但也更难掌握,之后的联系中加强这方面的练习;
//sstream头文件带来的stringstream 的流输入在分割单词的时候真心好用的不得了;
//汝佳大法好,set不得了;Orz。。


code:
#include <iostream>
#include <set>
#include <string>
#include <sstream>
#include <cstdio>
using namespace std;

set<string> dic;

int main()
{
    string str,ans;
    while(cin>>str)
    {
        int len=str.size();
        //cout<<len;
        for(int i=0; i<len; i++)
        {
            if(isalpha(str[i]))
            {
                str[i]=tolower(str[i]);//必须用等式来重新赋值;
            }
            else
            {
                str[i]=' ';//将标点符号转变为可以被cin识别的空格;
            }
        }
        stringstream ss(str);//创建流;
        while(ss >> ans)
        {
            dic.insert(ans);
        }
    }
    set<string>::iterator it;//定义迭代器;
    for(set<it=dic.begin(); it!=dic.end(); ++it)//循环中这种写法最好
    {
        cout<<*it<<endl;//迭代器相当于指针,意思是用法和指针类似;
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值