uvaoj-10391:conpound words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

 

Sample Output

alien
newborn


题解:刘汝佳白书135页练习题5-5;思路是用map来标记单词是否出现过,然后将单词进行分割;这种方法的时间复杂度是O(N);

不然用遍历的话强行暴力绝对会TLE;

新知识就是substr的运用,string真心好用;


code:

#include <iostream>
#include <map>
#include <string>
using namespace std;
map<string,bool> m;
int main()
{
    string s[150000];
    string str;
    string sa,sb;
    int cnt=0;
    while(cin>>str)
    {
        s[cnt++]=str;
        m[str]=1;
    }
    for(int i=0; i<cnt; i++)
    {
        for(int j=0,len=s[i].size(); j<len-1; j++)
        {
            sa=s[i].substr(0,j+1);
            sb=s[i].substr(j+1);
            if(m[sa]==1&&m[sb]==1)
            {
                cout<<s[i]<<endl;
                break;
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值