zju1037题解

题目:

 

Gridland


Time Limit: 1 Second      Memory Limit: 32768 KB


Background

For years, computer scientists have been trying to find efficient solutions to different computing problems. For some of them efficient algorithms are already available, these are the "easy" problems like sorting, evaluating a polynomial or finding the shortest path in a graph. For the "hard" ones only exponential-time algorithms are known. The traveling-salesman problem belongs to this latter group. Given a set of N towns and roads between these towns, the problem is to compute the shortest path allowing a salesman to visit each of the towns once and only once and return to the starting point.


Problem

The president of Gridland has hired you to design a program that calculates the length of the shortest traveling-salesman tour for the towns in the country. In Gridland, there is one town at each of the points of a rectangular grid. Roads run from every town in the directions North, Northwest, West, Southwest, South, Southeast, East, and Northeast, provided that there is a neighbouring town in that direction. The distance between neighbouring towns in directions North-South or East-West is 1 unit. The length of the roads is measured by the Euclidean distance. For example, Figure 7 shows 2 * 3-Gridland, i.e., a rectangular grid of dimensions 2 by 3. In 2 * 3-Gridland, the shortest tour has length 6.

 
Figure 7: A traveling-salesman tour in 2 * 3-Gridland.

Input

The first line contains the number of scenarios.

For each scenario, the grid dimensions m and n will be given as two integer numbers in a single line, separated by a single blank, satisfying 1 < m < 50 and 1 < n < 50.


Output

The output for each scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. In the next line, print the length of the shortest traveling-salesman tour rounded to two decimal digits. The output for every scenario ends with a blank line.


Sample Input

2
2 2
2 3


Sample Output

Scenario #1:
4.00

Scenario #2:
6.00 


 

Source: Northwestern Europe 2001

题目大意就是说,有一个叫gridland的国家,给出n个城市,及城市之间的距离,问题是寻找一条最短路径让售货员访问每个城市一次且只有一次,又回到出发点,gridland的总统让你去编写一个程序,计算在这个国家中所有城市的旅行售货员问题的最短长度,在gridland,每个城市位于矩形网络的一个点上,通向每个城市的道路只有东,西,南,北,东北,东南,西南,西北,方向,在每个方向只有一个相邻的城市,,东西南北方向上的长度为1,长度单位为欧几里得距离,如图,最短环游路线长度是6。

算法分析:通过简单的画图,我们可以得知,如果输入的长与宽的乘积为偶数那么最短的距离就是长与宽的乘积,即最短距离为m*n,如果输入的长与宽的乘积为奇数,那么就需要走一条斜边来代替一条直边,即最短距离为m*n-1+sqrt(2),最后就是注意结果要保留两位小数!

代码:

语言:c

#include<stdio.h>

#include<math.h>

int main()

{

int n,i,a,b;

scanf("%d",&n);

for(i=1;i<=n;i++)

{

scanf("%d%d",&a,&b);

if((a*b)%2==0)

{

printf("Scenario #%d:/n",i);

printf("%.2f/n",(float)a*(float)b);

}

else

{

printf("Scenario #%d:/n",i);

printf("%.2f/n",(float)(a*b-1)+sqrt(2.0));

}

if(i!=n)

{

printf("/n");

}

}

return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值