Paint Chainhdu3980

Paint Chain

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1741 Accepted Submission(s): 595

Problem Description
Aekdycoin and abcdxyzk are playing a game. They get a circle chain with some beads. Initially none of the beads is painted. They take turns to paint the chain. In Each turn one player must paint a unpainted beads. Whoever is unable to paint in his turn lose the game. Aekdycoin will take the first move.

Now, they thought this game is too simple, and they want to change some rules. In each turn one player must select a certain number of consecutive unpainted beads to paint. The other rules is The same as the original. Who will win under the rules ?You may assume that both of them are so clever.

Input
First line contains T, the number of test cases. Following T line contain 2 integer N, M, indicate the chain has N beads, and each turn one player must paint M consecutive beads. (1 <= N, M <= 1000)

Output
For each case, print “Case #idx: ” first where idx is the case number start from 1, and the name of the winner.

Sample Input
2
3 1
4 2

Sample Output
Case #1: aekdycoin
Case #2: abcdxyzk

Author
jayi

Source
2011 Multi-University Training Contest 14 - Host by FZU

Recommend

题意:
两个人给一个一共有n个珠子的环涂色。每次涂连续的m个珠子。不能涂色的那个人输。
思路:
典型的博弈。求出每一段的sg 4即可。因为题目中要求的东西是环,所以假定先手的那个取任意一段,然后从其中断开成一条链即可。
代码:

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;



int n,m;

int g[1007];

int sg(int x)
{
    if(x<m)
        return g[x]=0;
    if(g[x]!=-1)
        return g[x];
    int tmp=0;
    int s[1007];
    memset(s,0,sizeof s);
    for(int i=0;i<x&&x-i-m>=0;i++)
    {
        s[sg(i)^sg(x-i-m)]=1;
    }
    for(int i=0;i<1001;i++)
    {
        if(s[i]==0)
        {
            g[x]=i;
            break;
        }
    }
    return g[x];
}

int main()
{
    int T;
    int cas=1;
    scanf("%d",&T);
    while(T--)
    {
        memset(g,-1,sizeof g);

        scanf("%d%d",&n,&m);
        if(n<m || sg(n-m))
        {
            printf("Case #%d: abcdxyzk\n",cas++);
        }
        else
            printf("Case #%d: aekdycoin\n",cas++);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值