hdu-1238-Substrings-c语言


Problem Description

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input

The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.

Output

There should be one line per test case containing the length of the largest string found.

Sample Input

2
3
ABCD
BCDFF
BRCD
2
rose
orchid

Sample Output

2
2


#include<stdio.h>
#include<string.h>
#include<limits.h>
int getmin(char str[][110],int n)
{
    int min=INT_MAX,a;
    int i;
    for(i=0;i<n;i++)
    {
        if(min>strlen(str[i]))
        {
            min=strlen(str[i]);
            a=i;
        }
    }
    return a;
}
int main()
{
    char s1[110],s2[110];
    char str[110][110];
    int t,n,min,len,max;
    int i,j,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%s",str[i]);
        }
        min=getmin(str,n);
        max=0;
        len=strlen(str[min]);
        int flag=0;
        for(i=0;i<len;i++)
        {
            for(j=i;j<len;j++)
            {
                for(k=i;k<=j;k++)
                {
                    s1[k-i]=str[min][k];
                    s2[j-k]=str[min][k];
                }
                s2[j-i+1]=s1[j-i+1]='\0';
                int len1=strlen(s1);
                for(k=0;k<n;k++)
                {
                    if(strstr(str[k],s1)==NULL&&strstr(str[k],s2)==NULL)
                    {
                        flag=0;
                        break;
                    }
                }
                if(len1>max&&flag==1)
                max=len1;
                flag=1;
            }
        }
        printf("%d\n",max);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值