Dragon Balls​​​​​​​—并查集路径压缩

HDU-3635-Dragon Balls

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000). 
Each of the following Q lines contains either a fact or a question as the follow format: 
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different. 
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

题意:有N个龙珠,每个龙珠初始时都在本身的城市(第i个龙珠在第i个城市)。

现在有2种操作:

T A B,表示把A球所在城市全部的龙珠全部转移到B城市。(第一次时,因为A球所在的城市只有一个球,所以只移动1个,如果有多个,则全部移动)。

Q A,表示查询A。要求得到的信息分别是:A现在所在的城市,A所在城市的龙珠数目,A转移到该城市移动的次数(如果没有移动就输出0)

分析:一开始肯定会想建立数组暴力查询,但此题数据很大,肯定超时。

可以想到用并查集做,要三个数组,pre[i]代表龙珠i的初始节点,dis[i]代表龙珠i移动的次数,cn[i]代表i城市的龙珠数量。

主要问题还是查询龙珠移动的次数,一个一个的加是肯定不行的,可以放到路径压缩里面,每次调用的时候就会计算,还要注意输出格式,代码里可以详细看看。

#include<stdio.h>
#include<string.h>
int pre[10010],cn[10010],dis[10010];
int find(int x)
{
	if(x == pre[x]) return x;
	int root = pre[x];
	pre[x] = find(pre[x]);
	dis[x] += dis[root]; //要从初始节点往下依次加上上一个节点移动的次数
	return pre[x];
}
void join(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx != fy){
		cn[fy] += cn[fx]; //一定记得加的是龙珠所在位置所有的龙珠,所以是初始节点之间相加
		cn[fx] = 0;
		dis[fx]++;
		pre[fx] = fy;
	}
}
int main()
{
	int t,n,q,m,i,kase=1;
	scanf("%d",&t);
	while(t--)
	{
		char s[2];
		int a,b;
		memset(dis,0,sizeof dis);//初始化
		scanf("%d%d",&n,&q);
		for(i = 1; i<= n; i++){//两个数组的初始化
			pre[i] = i;
			cn[i] = 1;
		}
		printf("Case %d:\n",kase++);//记得这个的位置
		while(q--)
		{
			scanf("%s",&s);
			if(s[0] == 'T'){
				scanf("%d%d",&a,&b);
				join(a,b);
			}
			else if(s[0] == 'Q'){
				scanf("%d",&a);
				int z = find(a);//在调用的同时就知道了数量和次数
				printf("%d %d %d\n",z,cn[z],dis[a]);//弄清楚题目让输出的是什么
			}
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值