HDU-3047-带权并查集

HDU-3047-Zjnu Stadium

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite. 
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2). 
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R. 

Input

There are many test cases: 
For every case: 
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space. 
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space. 
 

Output

For every case: 
Output R, represents the number of incorrect request. 

Sample Input

10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100

Sample Output

2

首先要读懂题,我也是读了老半天才懂,题意就是:

一个体育场,行数不限,一列有300个座位,编号1~300,给你n,m,代表n个人,m行,有m行是人与人座位之间的关系。

之后m行中有a,b,s,代表b坐在a之后距离a为s的座位,中间可能有矛盾的座位,就是多个人在一个座位那种,让你求出它的个数。

 

分析:由于数很大,可以考虑用并查集做,由于题意给出行数可以视为无限多,所以只考虑在一个集合中的人座位是否矛盾就行。

假设输入x,y,s,要将a,b所在的集合合为一起,就是把x,y的初始节点fx,fy合到一起。

dis[i]表示i到初始节点的距离

已知dis[x] = x ——> fx,dis[y] = y ——> fy,s = y——>x;要求 fy——>fx;可以画出关系图。

通过向量的运算可以知道 dis[fy] = -dis[y] + s + dis[x],即本题的核心公式。

#include<stdio.h>
int pre[50010],dis[50010],cnt;//cnt是计数的
int find(int x)
{
	if(x == pre[x]) return x;
	int root = pre[x];//下面的是在每一次添加的时候从初始节点依次计算子节点的dis,要用递归
	pre[x] = find(pre[x]);
	dis[x] += dis[root];
	return pre[x];
}
void join(int x,int y,int s)
{
	int fx=find(x),fy=find(y);
	if(fx != fy){
		pre[fy] = fx;
		dis[fy]=dis[x]+s-dis[y];//这是核心,可以自己画一下图理解
	}
	else{//一定要有else判断
		if(dis[y]-dis[x]!=s){这个是判断加入一个新的关系后是否与之前的矛盾
			cnt++;
		}
	}
}
int main()
{
	int n,m,a,b,c,i;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		cnt = 0;
		for(i = 1;i <= n ; i++){
			pre[i] = i;
			dis[i] = 0;
		}
		while(m--){
			scanf("%d %d %d",&a,&b,&c);
			join(a,b,c);
		}
		printf("%d\n",cnt);
	}
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值