队列广搜

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the
shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard
exactly once. He thinks that the most difficult part of the problem is determining the smallest number
of knight moves between two given squares and that, once you have accomplished this, finding the tour
would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the
”difficult” part.
Your job is to write a program that takes two squares a and b as input and then determines the
number of knight moves on a shortest route from a to b.
Input
The input file will contain one or more test cases. Each test case consists of one line containing two
squares separated by one space. A square is a string consisting of a letter (a…h) representing the column
and a digit (1…8) representing the row on the chessboard.
Output
For each test case, print one line saying ‘To get from xx to yy takes n knight moves.’.
Sample Input
e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6
Sample Output
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.
用队列来写广搜
q. empty()若队列为空,返回true,否则返回false
q.size()返回队列中元素 个数
q.pop()删除队首元素
q. front()返回队首元素的值,但不删除该元素(仅适用于F
IFO队列)
q.back( )
返回队尾元素的值,但不删除该元素(仅适用于F
IFO队列)
q. top() 返回具有最高优先级的元素的值,但不删除该元
素(仅适用于优先队列)
q.push()对queue在队尾压入- 一个新元素
对pr ior ity_ _queue在 基于优先级的适当位置
插入新元素*/
代码如下

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
#define N 10
int G[N][N];
int dir[8][2]= {{1,-2},{2,-1},{2,1},{1,2},{-1,2},{-2,1},{-2,-1},{-1,-2}};
int step;
int sx,sy,fx,fy;
struct node
{
    int x,y,step;
};
void bfs()
{
    memset(G,0,sizeof(G));
    queue<node> q;
    node p,next;
    p.x=sx;
    p.y=sy;
    p.step=0;
    G[p.x][p.y]=1;
    q.push(p);

    while(!q.empty())
    {
        p=q.front();
        q.pop();

        if(p.x==fx&&p.y==fy)
        {
            step=p.step;
            return ;
        }

        for(int i=0; i<8; i++)
        {
            next.x=p.x+dir[i][0];
            next.y=p.y+dir[i][1];

            if(next.x>=1&&next.y>=1&&next.x<=8&&next.y<=8&&G[next.x][next.y]==0)
            {
                next.step=p.step+1;
                G[next.x][next.y]=1;
                q.push(next);
            }
        }
    }
}
int main()
{
    char c1,c2;
    int y1,y2;
    while(~scanf("%c%d %c%d",&c1,&y1,&c2,&y2))
    {
        getchar();
        sx=c1-'a'+1;
        sy=y1;
        fx=c2-'a'+1;
        fy=y2;
        bfs();
        printf("To get from %c%d to %c%d takes %d knight moves.\n",c1,y1,c2,y2,step);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值