【UVa 11300】&【BZOJ 1045】【HAOI 2008】推一发

Description

  有n个小朋友坐成一圈,每人有ai个糖果。每人只能给左右两人传递糖果。每人每次传递一个糖果代价为1。

Input

  第一行一个正整数n<=987654321,表示小朋友的个数.接下来n行,每行一个整数ai,表示第i个小朋友得到的糖果的颗数.

Output

  求使所有人获得均等糖果的最小代价。

Sample Input

4
1
2
5
4

Sample Output

4

题解

详见白书《训练指南》P5

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

#define N 1000010
typedef long long ll;
ll a[N],c[N],tot,m,n;

int main()
{
    scanf("%lld",&n);
    for(int i = 1;i <= n;i++)
    {
        scanf("%lld",&a[i]);
        tot += a[i];
    }
    m = tot / n;
    c[0] = 0;
    for(int i = 1;i < n;i++) c[i] = c[i-1] + a[i] - m;
    sort(c,c+n);
    m = c[n/2]; tot = 0;
    for(int i = 0;i < n;i++) tot += abs(m - c[i]);
    printf("%lld\n",tot);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值