BFS(三维图)-Dungeon Master POJ - 2251

BFS(三维图)-Dungeon Master POJ - 2251

三维图的迷宫问题,其实是个纸老虎,和二维一样,定义三维矩阵再把搜索方向拓展为六个方向即可。
题目:
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input
3 4 5
S…
.###.
.##…
###.#

##.##
##…

#.###
####E

1 3 3
S##
#E#

0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!

题意:
给定一个长宽高分别为L,R,C三维图,输出从起点S到终点E的最短时间,若无法到终点输出”Trapped!“。

思路:
换汤不换药,图定义成三维矩阵,搜索方向拓展到上下左右前后六个方向即可。

#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cstdio>
using namespace std;
int L,R,C,i,j,k;
struct node
{
    int x,y,z,step;
};
char mp[35][35][35];
bool vis[35][35][35];
int dir[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
queue<node>Q;
node n1;
int bfs()
{
    Q.push(n1);
    vis[n1.x][n1.y][n1.z]=true;
    if(mp[n1.x][n1.y][n1.z]=='E') return 0;
    while(!Q.empty())
    {
        node n2=Q.front();
        Q.pop();
        for(int m=0;m<6;m++)
        {
            n1.x=n2.x+dir[m][0];
            n1.y=n2.y+dir[m][1];
            n1.z=n2.z+dir[m][2];
            n1.step=n2.step+1;
            if(mp[n1.x][n1.y][n1.z]=='E')
            {
                while(!Q.empty())
                    Q.pop();
                return n1.step;
            }
            if(mp[n1.x][n1.y][n1.z]=='.'&&!vis[n1.x][n1.y][n1.z])
            {
                Q.push(n1);
                vis[n1.x][n1.y][n1.z]=true;
            }
        }
    }
    return -1;
}
int main()
{
    while(cin>>L>>R>>C)
    {
        if(L==0&&R==0&&C==0) break;
        memset(vis,false,sizeof(vis));//这里一开始写成sizeof(false),md傻傻调了半个多小时还以为是memset玄学,最后还是队友帮忙发现了
        memset(mp,'!',sizeof(mp));
        for(i=1;i<=L;i++)
            for(j=1;j<=R;j++)
                for(k=1;k<=C;k++)
                {
                    cin>>mp[i][j][k];
                    if(mp[i][j][k]=='S')
                    {
                        n1.x=i,n1.y=j,n1.z=k,n1.step=0;
                    }
                }
        int ans=bfs();
        if(ans!=-1) printf("Escaped in %d minute(s).\n",ans);
        else cout<<"Trapped!"<<endl;
    }
    return 0;
}

总结:
细心啊!
sizeof(false)可还行(草


2020 − 2 − 28 2020-2-28 2020228

又 写 了 一 遍 又写了一遍

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define P pair<int,int>
#define ll long long
#define inf 0x7fffffff
using namespace std;
const int N=110;
int l,r,c;
char mp[N][N][N];
int dis[N][N][N];
int dir[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
struct node
{
    int x,y,z;
    bool operator == (const node & t)const
    {
        return t.x==x&&t.y==y&&t.z==z;
    }
};
void bfs(node S,node E)
{
    if(S==E) {dis[E.x][E.y][E.z]=0; return;}
    queue<node>Q;
    dis[S.x][S.y][S.z]=0;
    Q.push(S);
    while(!Q.empty())
    {
        node tmp=Q.front();
        Q.pop();
        for(int i=0;i<6;i++)
        {
            int x=tmp.x+dir[i][0];
            int y=tmp.y+dir[i][1];
            int z=tmp.z+dir[i][2];
            if(x<1||y<1||z<1||x>l||y>r||z>c||mp[x][y][z]=='#'||dis[x][y][z]!=-1) continue;
            node tmp1={x,y,z};
            Q.push(tmp1);
            dis[x][y][z]=dis[tmp.x][tmp.y][tmp.z]+1;
            if(tmp1==E) return;
        }
    }
}

int main()
{
    while(~scanf("%d%d%d",&l,&r,&c),l||r||c)
    {
        node S,E;
        memset(dis,-1,sizeof(dis));
        for(int i=1;i<=l;i++)
            for(int j=1;j<=r;j++)
                for(int k=1;k<=c;k++)
                {
                     cin>>mp[i][j][k];
                     if(mp[i][j][k]=='S')
                        S={i,j,k};
                    else if(mp[i][j][k]=='E')
                        E={i,j,k};
                }
        bfs(S,E);

        if(dis[E.x][E.y][E.z]!=-1) printf("Escaped in %d minute(s).\n",dis[E.x][E.y][E.z]);
        else cout<<"Trapped!"<<endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值