Floyed-Cow Contest POJ - 3660

Cow Contest POJ - 3660

题目:
N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

题意:
输入奶牛的数量N,奶牛间PK的回合数M,M个回合的结果(前者胜,后者负),问最终可以确定几头奶牛的排名。

思路:
N<=100,考虑floyed。
利用传递性质,判断图中各点到剩余所有点的是否联通(存在单项联通即可),输出这样的点的数量。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=105;
int N,M,a[maxn][maxn],ans=0;

int main()
{
    cin>>N>>M;
    memset(a,0,sizeof(a));
    for(int i=0;i<M;i++)
    {
        int u,v;
        scanf("%d%d",&u,&v);
        a[u][v]=1;
    }
    for(int k=1;k<=N;k++)
        for(int i=1;i<=N;i++)
            for(int j=1;j<=N;j++)
                if(a[i][k]&&a[k][j])
                    a[i][j]=1;//如果i打败k,k打败j,则i打败j-----传递闭包

    for(int i=1;i<=N;i++)
    {
        int tmp=0;//第一层循环内,每个点需要重新置零
        for(int j=1;j<=N;j++)
        {
            if(a[i][j]||a[j][i])//i与j之间的胜负关系确定(联通)
                tmp++;
        }
        if(tmp==N-1) ans++;//与剩余N-1个点的关系都确定(都存在单向联通)
    }
    cout<<ans<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值