最短路径__Cow Contest ( Poj 3660)

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题目大意:
        有n只奶牛,有n个连续的实力,如果u的实力大于v的实力,就能打赢它,
        然后给定m种关系,求最后能确定其排名的奶牛个数。
解题思路:
        一开始用dij的最长路去求,发现有一种典型的DAG求不了,而传递闭包可以
       快速求解。其实dij可行,但是麻烦。没有floyd那么简洁优美啊。用floyd,求
       出每个点能到达的点。如果有一个点,排名在它之前的和排名在它之后的点之
       和为n-1,那么它的排名就是确定的。



#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define N 110
#define INF 999999999
int mpt[N][N];
int visit[N];
int dis[N];
int n,m;
int main()
{
    int i,j,k;
    int a,b;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        for(i = 1 ; i <= n ; i ++)
        {
            for(j = 1 ; j <= n ; j ++)
            {
                mpt[i][j] = 0;
            }
        }
        for(i = 0 ; i < m ; i ++)
        {
            scanf("%d%d",&a,&b);
            mpt[a][b] = 1;
            mpt[b][a] = -1;
        }
        for(i = 1 ; i <= n ; i ++)
        {
            for(j = 1; j <= n ; j ++)
            {
                for(k = 1; k <= n ; k ++)
                {
                    if(mpt[i][k] == 1 && mpt[k][j] == 1){
                            mpt[i][j] = 1;
                            mpt[j][i] = -1;
                    }
                    if(mpt[j][k] == 1 && mpt[k][i] == 1){
                        mpt[j][i] = 1;
                        mpt[i][j] = -1;
                    }
                }
            }
        }
        int ans = 0;
        for(i = 1; i <= n ; i++)
        {
            int c = 0;
            for(j = 1 ; j <= n ; j ++)
            {
                if(mpt[i][j] != 0)c++;
            }
            if( c == n - 1 )ans ++;
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值