HDU-4300 Clairewd’s message(扩展KMP)

Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7958    Accepted Submission(s): 2940


Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;
 

Output
For each test case, output one line contains the shorest possible complete text.
 

Sample Input
  
  
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde
 

Sample Output
  
  
abcdabcd qwertabcde
 题意:此题题意略微恶心,简单说来:第一行输入26个字母,分别代表abcd...z,下面一行是密文+明文,但是明文可能没有显示全,要求输出最短的密文+明文.
思路:扩展KMP, 这篇文章讲的挺好的。   
然后我们可以一个数组存原串,另一个存译串,求原串的extend数组,然后我们从len/2处开始往后求最大的extend[i]并且是extend[i] = len-i,其实就是第一个extend[i] = len-i处即为明文的第一个字符.

代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<cmath> 
#include<map>
#define mem(a,b) memset(a,b,sizeof(a))
#define mod 1000000007
using namespace std;
typedef long long ll;
const int maxn = 1e5+5;
const double esp = 1e-7;
const int ff = 0x3f3f3f3f;

int ne[maxn],ex[maxn];
char s[maxn],t[maxn],vis[30];

void get_next(char *s,int len)
{
	ne[0] = len;
	int a = 0,p = 0;
	for(int i = 1;i< len;i++)
	{
		if(i>= p||i+ne[i-a]>= p)
		{
			if(i> p)
				p = i;
			
			while(p< len&&s[p] == s[p-i])
				p++;
			
			ne[i] = p-i;
			a = i;
		}
		else
			ne[i] = ne[i-a];
	}
}

void get_extend(char *s,int len1,char *t,int len2)//记住板子 
{
	int a = 0,p = 0;
	for(int i = 0;i< len1;i++)
	{
		if(i>= p||i+ne[i-a]>= p)
		{
			if(i>= p)
				p = i;
			
			while(p< len1&&p-i< len2&&s[p] == t[p-i])
				p++;
			
			ex[i] = p-i;
			a = i;
		}
		else
			ex[i] = ne[i-a];
	}
}

int main()
{
	int tt;
	cin>>tt;
	while(tt--)
	{
		mem(ne,0);
		mem(ex,0);
		for(int i = 0;i< 26;i++)
		{
			char c;
			scanf(" %c",&c);
			vis[c-'a'] = 'a'+i;;
		}
		scanf(" %s",t);
		
		int len = strlen(t);
		for(int i = 0;i< len;i++)
			s[i] = vis[t[i]-'a'];
		
		get_next(s,len);
		get_extend(t,len,s,len);
		
		int ans = len;
		for(int i = (len+1)/2;i< len;i++)
		{
			if(ex[i] == len-i)//找到了明文第一个字符 
			{
				ans = i;
				break;
			}
		}
		
		for(int i = 0;i< ans;i++)
			printf("%c",t[i]);
		for(int i = 0;i< ans;i++)
			printf("%c",s[i]);
		printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值