HDU4300:Clairewd’s message

Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;
 

Output
For each test case, output one line contains the shorest possible complete text.
 

Sample Input
  
  
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde
 

Sample Output
  
  
abcdabcd qwertabcde
 


 

/*
题意为:给定一个翻译表,即第i个字母用哪个字母表示

再给一个串,里面前面为密文,后面为明文,密文一定是完整的,但明文不完整或可能没有

求这个完整的前面密文后面明文的串





把给定的串全部按表翻译为密文,这样例如样例
qwertabcde

翻译之后为:

 jvtkzqwert

可发现翻译后的后半部分与原传相同,把原串作为T串,翻译后的为S串,求B

题目要求求最短长度, 从B的一半开始, 当找到第一个满足 B[i]== len- i条件的,i即为第一个明文的位置

*/

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;

int next[100005];
char str[27];
char s1[100005],s2[100005];

void getnext(char *t)
{
    int i = 0,j = -1;
    next[0] = -1;
    while(t[i])
    {
        if(j == -1 || t[i] == t[j])
        {
            i++;
            j++;
            next[i] = j;
        }
        else
            j = next[j];
    }
}

int kmp(char *s,char *t)
{
    int i = 0,j = 0;
    int slen =strlen(s),tlen = strlen(t);
    getnext(t);
    while(i<slen && j<tlen)
    {
        if(j == -1 || s[i] == t[j])
        {
            i++;
            j++;
            if(i == slen)
                return j;
        }
        else
            j = next[j];
    }
    return 0;
}

int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        scanf("%s",str);
        scanf("%s",s1);
        int len = strlen(s1);
        strcpy(s2,s1+(len+1)/2);
        printf("%s",s1);
        for(int i = 0; s1[i]; i++)
        {
            for(int j = 0; j<26; j++)
            {
                if(s1[i] == str[j])
                {
                    s1[i] = 'a'+j;
                    break;
                }
            }
        }
        int flag = kmp(s2,s1);
        for(int i = flag; i<len-flag; i++)
        {
            printf("%c",s1[i]);
        }
        cout << endl;
    }

    return 0;
}


 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值