1015 Reversible Primes(素数判断+进制转换)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10^​5​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

#include<cstdio>
#include<cmath>
using namespace std;
const int maxn=100100;
bool judge(int n){//这个是单纯判断是否是素数的写法。素数表的写法另行复习 
	if(n<=1) return false;
	int sq=int(sqrt(n*1.0));
	for(int i=2;i<=sq;i++){
		if(n%i==0)
			return false;
	}
	return true;
}
int main(){
	int n,d;
	while(~scanf("%d",&n)){
		if(n<0)
			break;
		scanf("%d",&d);
		if(judge(n)==false){
			printf("No\n");
			continue;
		}
		int array[100];//100000的二进制也不过17位
		int len=0;
	/*
		下面这段如果d是二进制,八进制等不好理解的进制就不要硬钻,用135和10进制当例子来理解。
		所有进制算法步骤都一样,实质都一样,不要过多纠结。 
	*/
		do{//把n按d进制转换后逆序存储 
			array[len++]=n%d;
			n/=d;
		}while(n);
		for(int i=0;i<len;i++){
			n=n*d+array[i];
		}
		printf("%s",judge(n)?"Yes\n":"No\n");
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值