hdu5583_Kingdom of Black and White_思维

Problem Description
In the Kingdom of Black and White (KBW), there are two kinds of frogs: black frog and white frog.

Now N frogs are standing in a line, some of them are black, the others are white. The total strength of those frogs are calculated by dividing the line into minimum parts, each part should still be continuous, and can only contain one kind of frog. Then the strength is the sum of the squared length for each part.

However, an old, evil witch comes, and tells the frogs that she will change the color of at most one frog and thus the strength of those frogs might change.

The frogs wonder the maximum possible strength after the witch finishes her job.
 

Input
First line contains an integer T , which indicates the number of test cases.

Every test case only contains a string with length N , including only 0 (representing
a black frog) and 1 (representing a white frog).

1T50 .

for 60% data, 1N1000 .

for 100% data, 1N105 .

the string only contains 0 and 1.
 

Output
For every test case, you should output " Case #x: y",where x indicates the case number and counts from 1 and y is the answer.
 

Sample Input
  
  
2 000011 0101
 

Sample Output
  
  
Case #1: 26 Case #2: 10

题意:

给你一个串,由01组成,需要改变一个串(将1改成0,或者将0改成1),使得最后的连续的串的个数的平方和最大

解:

将字符串处理成数字存在数组里,求解改变后的数值变化与之前的数值差值最大的那个位置就行。

在改变数值的时候有三种情况,如串长为4 5这组,有3  6前减后加的情况,有5 4前加后减的情况,以及5 1 2这组中合并为8的情况。

分别处理就行了。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
using namespace std;
typedef long long ll;
const int inf=0x3f3f3f3f;
const int maxn=1e5+50;
char str[maxn];ll cnt[maxn];
int main()
{
    int t;
    scanf("%d",&t);
    int cas=0;
    while(t--)
    {
        memset(cnt,0,sizeof(cnt));
        scanf("%s",str);
        int len=strlen(str);
        char p=str[0];
        ll k=0,num=1;
        ll sum=0;
        if(len==1)
        {printf("Case #%d: 1\n",++cas);continue;}
        for(int i=1;i<len;i++)
        {
            if(str[i]!=p)
            {
                cnt[k++]=num;
                sum+=num*num;
                num=1;
                p=str[i];
            }
            else
            {
                num++;
            }
            if(i==len-1)
            {
                cnt[k++]=num;
                sum+=num*num;

            }
        }
        /*for(int i=0;i<k;i++)
        cout<<cnt[i]<<" ";
        cout<<endl;
        cout<<sum<<endl;*/
        ll sum1=0,pos=0,sum2=0,pos1=0;ll cha=0;
        for(int i=0;i<k-1;i++)
        {
            int a=cnt[i]+1,b=cnt[i+1]-1,c=cnt[i]-1,d=cnt[i+1]+1;
            //cout<<"ABCD:"<<a<<" "<<b<<" "<<c<<" "<<d<<endl;
            if(b==0)
            {
                if(i+2<k)
                {
                    sum2=(a+cnt[i+2])*(a+cnt[i+2]);
                    pos1=cnt[i]*cnt[i]+cnt[i+1]*cnt[i+1]+cnt[i+2]*cnt[i+2];
                    if(abs(sum2-pos1)>cha)
                    {
                        cha=abs(sum2-pos1);
                        sum1=sum2;
                        pos=pos1;
                    }
                    else
                    continue;
                }
                else
                {
                    sum2=a*a;
                    pos1=cnt[i]*cnt[i]+cnt[i+1]*cnt[i+1];
                    if(abs(sum2-pos1)>cha)
                    {
                        cha=abs(sum2-pos1);
                        sum1=sum2;
                        pos=pos1;
                    }
                    else
                    continue;
                }
            }
            if(c==0)
            {
                if((i-1)>=0)
                {
                    sum2=(d+cnt[i-1])*(d+cnt[i-1]);
                    pos1=cnt[i-1]*cnt[i-1]+cnt[i]*cnt[i]+cnt[i+1]*cnt[i+1];
                    if(abs(sum2-pos1)>cha)
                    {
                        cha=abs(sum2-pos1);
                        sum1=sum2;
                        pos=pos1;
                    }
                    else
                    continue;
                }
                else
                {
                    sum2=d*d;
                    pos1=cnt[i]*cnt[i]+cnt[i+1]*cnt[i+1];
                    if(abs(sum2-pos1)>cha)
                    {
                        cha=abs(sum2-pos1);
                        sum1=sum2;
                        pos=pos1;
                    }
                    else
                    continue;
                }
            }
            if(b!=0&&c!=0)
            {
                int tmp=(a*a)+(b*b);
                int tmp2=(c*c)+(d*d);
                //cout<<"TMP:"<<tmp<<" TMP2:"<<tmp2<<endl;
                sum2=tmp;
                pos1=cnt[i]*cnt[i]+cnt[i+1]*cnt[i+1];
                if(abs(sum2-pos1)>cha)
                    {
                        cha=abs(sum2-pos1);
                        sum1=sum2;
                        pos=pos1;
                    }
                sum2=tmp2;
                pos1=cnt[i]*cnt[i]+cnt[i+1]*cnt[i+1];
                if(abs(sum2-pos1)>cha)
                    {
                        cha=abs(sum2-pos1);
                        sum1=sum2;
                        pos=pos1;
                    }
            }
        }

        //cout<<"POS:"<<pos<<" SUM1:"<<sum1<<endl;
        printf("Case #%d: %lld\n",++cas,sum-pos+sum1);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,关于 HDU4992 求所有原根的问题,我可以给出以下解答: 1. 首先,我们需要知道什么是原根。原根是指模 n 意义下,所有与 n 互质的数 a 的最小正整数 k 次幂对 n 取模的值覆盖了所有与 n 互质的数。简单来说,就是如果一个数 a 是模 n 意义下的原根,那么 a 的任何正整数次幂对 n 取模的值都不相同,且能覆盖所有与 n 互质的数。 2. 为了求模 n 意义下的所有原根,我们需要先求出与 n 互质的数的个数 phi(n)。phi(n) 可以使用欧拉函数求出。 3. 然后,我们需要枚举模 n 意义下的所有数,判断它是否是原根。具体来说,对于每个 a,我们需要判断 a 的每个小于 phi(n) 的正整数次幂对 n 取模的值是否都不相同,且能覆盖所有与 n 互质的数。如果是,那么 a 就是模 n 意义下的原根。 4. 代码实现可以参考以下 Java 代码: ``` import java.util.*; public class Main { static int gcd(int a, int b) { return b == 0 ? a : gcd(b, a % b); } static int phi(int n) { int res = n; for (int i = 2; i * i <= n; i++) { if (n % i == 0) { res = res / i * (i - 1); while (n % i == 0) { n /= i; } } } if (n > 1) { res = res / n * (n - 1); } return res; } static int pow(int a, int b, int mod) { int res = 1; while (b > 0) { if ((b & 1) != 0) { res = res * a % mod; } a = a * a % mod; b >>= 1; } return res; } static boolean check(int a, int n, int phi) { for (int i = 1, j = pow(a, i, n); i <= phi; i++, j = j * a % n) { if (j == 1) { return false; } } return true; } public static void main(String[] args) { Scanner scanner = new Scanner(System.in); while (scanner.hasNext()) { int n = scanner.nextInt(); int phi = phi(n); List<Integer> ans = new ArrayList<>(); for (int i = 1; i < n; i++) { if (gcd(i, n) == 1 && check(i, n, phi)) { ans.add(i); } } Collections.sort(ans); for (int x : ans) { System.out.print(x + " "); } System.out.println(); } } } ``` 其中,gcd 函数用于求最大公约数,phi 函数用于求欧拉函数,pow 函数用于快速幂求模,check 函数用于判断一个数是否是原根。在主函数中,我们依次读入每个 n,求出 phi(n),然后枚举模 n 意义下的所有数,判断它是否是原根,将所有原根存入一个 List 中,最后排序输出即可。 希望我的回答能够帮到你,如果你有任何问题,欢迎随时提出。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值