poj 3660(floyd, 传递性(离散数学))

Cow Contest

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15153 Accepted: 8461

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题意: 给定两两奶牛之间的 决斗胜利情况 , 问最后 能够确定奶牛等级的数量

思路: 如果一头 奶牛与 其余 n - 1 头奶牛的关系都确定, 那么 它的等级也就确定

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 110;
bool cmp[maxn][maxn];
int n,m;

void floyd(){
    for(int k = 1;k <= n;k ++)
        for(int i = 1;i <= n;i ++)
            for(int j = 1;j <= n;j ++)
                cmp[i][j] = cmp[i][j] || (cmp[i][k] && cmp[k][j]);
}

int main()
{
    while(~scanf("%d%d",&n,&m)){
        memset(cmp,0,sizeof(cmp));
        int a,b;
        for(int i = 0;i < m;i ++){
            scanf("%d%d",&a,&b);
            cmp[a][b] = 1;
        }
        floyd();
        int sum = 0,ans = 0;
        for(int i = 1;i <= n;i ++){
            sum = 0;
            for(int j = 1;j <= n;j ++)
                if(cmp[i][j] || cmp[j][i]) sum ++;
            if(sum == n - 1) ans ++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值