HDU - 4771 ​​​​​​​Stealing Harry Potter's Precious (dfs + bfs,dfs 暴力 tsp)

Stealing Harry Potter's Precious

Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below: 



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.

Input

  There are several test cases. 
  In each test cases: 
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100). 
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move. 
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank. 
  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y). 
  The input ends with N = 0 and M = 0 

Output

  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1. 

Sample Input

2 3
##@
#.#
1
2 2
4 4
#@##
....
####
....
2
2 1
2 4
0 0

Sample Output

-1
5

题意:给你一张 n * m 的地图,其中 @ 表示起点,' . ' 代表可走, ' # ' 代表不可走,然后有 k 个坐标,表示在 坐标处有宝藏。 题目现在要求 从 起点出发,得到所有宝藏的最小行走距离(上下左右移动一次距离为1),或者 输出 -1 ,表示不能得到所有宝藏。

思路:这个题和POJ 2688 几乎一样。 bfs 处理 起点 以及 宝藏 任意两个点之间的距离,然后用 dfs 暴力跑 tsp,求一遍最短距离。

AC代码:

#include<bits/stdc++.h>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define INT(t) int t; scanf("%d",&t)
#define LLI(t) LL t; scanf("%I64d",&t)

using namespace std;

const int inf = 0x3f3f3f3f;
char mp[150][150];
struct node{
    int x,y;
    int step;
    node(){}
    node(int x,int y,int step):
        x(x),y(y),step(step){}
}p[10];
int coun[150][150];
int vis[150][150];
int dis[10][10];
int to[4][2] = {1,0,-1,0,0,1,0,-1};
int n,m,k;

void bfs(node A,int cou){
    queue<node> Q;
    A.step = 0;
    vis[A.x][A.y] = 1;
    Q.push(A);
    while(!Q.empty()){
        node now = Q.front();
        if(mp[now.x][now.y] == '@' || mp[now.x][now.y] == 's'){
            dis[cou][coun[now.x][now.y]] = now.step;
            //printf("%d %d %d %d\n",cou,now.x,now.y,now.step);
        }
        Q.pop();
        for(int i = 0;i < 4;i ++){
            int tmpx = now.x + to[i][0];
            int tmpy = now.y + to[i][1];
            if(tmpx < 1 || tmpx > n || tmpy <1 || tmpy > m)
                continue;
            if(vis[tmpx][tmpy]) continue;
            if(mp[tmpx][tmpy] == '#') continue;
            vis[tmpx][tmpy] = 1;
            Q.push(node(tmpx,tmpy,now.step + 1));
        }
    }
}

int ans = inf;
int vis1[10];
void dfs(int f,int step,int disx){
    if(disx > ans) return ;
    if(step == k){
        ans = min(ans,disx);
        return ;
    }
    for(int i = 1;i <= k;i ++){
        if(vis1[i]) continue;
        vis1[i] = 1;
        dfs(i,step + 1,disx + dis[f][i]);
        vis1[i] = 0;
    }
}

int main()
{
    while(~scanf("%d%d",&n,&m) && (n || m)){
        clr(dis,inf); clr(vis1,0);
        ans = inf; clr(coun,0);

        rep(i,1,n + 1) scanf("%s",mp[i] + 1);

        rep(i,1,n + 1)
        rep(j,1,m + 1){
            if(mp[i][j] == '@')
                p[0].x = i,p[0].y = j;
        }

        scanf("%d",&k);
        int flag = 1;
        rep(i,1,k + 1){
            int x,y; scanf("%d%d",&x,&y);
            mp[x][y] = 's';
            p[i].x = x; p[i].y = y;
            coun[x][y] = i;
        }
        coun[0][0] = 0;

        rep(i,0,k + 1){
            clr(vis,0);
            bfs(p[i],i);
        }

//        for(int i = 0;i <= k;i ++,printf("\n"))
//            for(int j = 0;j <= k;j ++)
//                if(dis[i][j] == inf) printf(" inf");
//                else printf("%4d",dis[i][j]);

        rep(i,0,k + 1) rep(j,0,k + 1) if(dis[i][j] == inf) flag = 0;

        if(!flag) puts("-1");
        else {
            vis1[0] = 1;
            dfs(0,0,0);
            printf("%d\n",ans);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值