HDU 1394 (每次将序列第一个数放到最后形成一个新序列,求这些序列的逆序对的最小值)

Minimum Inversion Number

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 

You are asked to write a program to find the minimum inversion number out of the above sequences. 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 

Output

For each case, output the minimum inversion number on a single line. 

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

题意:给定一个序列,每次将序列第一个数放到最后形成一个新序列,求这些序列的逆序对的最小值。

思路:对于原序列算每个数 前后比其值的个数,以及前后比其的个数

如:

 62135
前大01211
后大02210
前小00023
后小41000

每一次将序列头移动至序列尾,得到的逆序对数目就是 ans += 前大 + 后大 - 前小 - 后小

如:将 6 移至序列尾,逆序对数目就是 5 + 0 + 0 - 0 - 4 = 1,序列为 2 1 3 5 6

将 2 移至序列尾,逆序对数目就是 1 + 1 + 2 - 0 - 1 = 3。。。

然后暴力处理这4个数组就可以了 (数据大的话,就用线段树处理这四个数组,但是好像挺麻烦)

AC代码:

#include<cstdio>
#include<algorithm>

using namespace std;

const int maxn = 5010;
int a[maxn];
int froBig[maxn],froSmal[maxn];
int behBig[maxn],behSmal[maxn];

int main() {
    int n;
    while(~scanf("%d",&n)){
        for(int i = 1;i <= n;++ i){
            scanf("%d",&a[i]);
        }
        int ans1 = 0;
        for(int i = 1;i <= n;++ i){
            int big = 0,smal = 0;
            for(int j = 1;j <= i - 1;++ j){
                if(a[j] > a[i]) ++ big;
                if(a[j] < a[i]) ++ smal;
            }
            ans1 += big;
            froBig[i] = big;
            froSmal[i] = smal;
        }
        for(int i = 1;i <= n;++ i){
            int big = 0,smal = 0;
            for(int j = n;j > i;-- j){
                if(a[j] > a[i]) ++ big;
                if(a[j] < a[i]) ++ smal;
            }
            behBig[i] = big;
            behSmal[i] = smal;
        }
        int minn = ans1;
        for(int i = 1;i < n;++ i){
            ans1 = ans1 + froBig[i] + behBig[i] - froSmal[i] - behSmal[i];
            minn = min(minn,ans1);
        }
        printf("%d\n",minn);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值