HDU - 2669 Romantic(扩展欧几里得 / 同余方程)

Romantic

The Sky is Sprite. 
The Birds is Fly in the Sky. 
The Wind is Wonderful. 
Blew Throw the Trees 
Trees are Shaking, Leaves are Falling. 
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei 

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! 
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 

Input

The input contains multiple test cases. 
Each case two nonnegative integer a,b (0<a, b<=2^31) 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3

题意:给定两个数a,b,能否找到非负整数X和整数Y,使得aX+bY=1,若有多组解输出 x 最小的一组

思路:扩展欧几里得。

显然,若 gcd(a,b) != 1,无解。

否则通过 扩展欧几里得 求得一组特解。

若gcd(a, b) = 1,则方程ax ≡ c (mod b)在[0, b-1]上有唯一解。所以最后 x 只需要再对 b 取模,然后通过 x 求得 y 即可。

AC代码:

#include<bits/stdc++.h>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define ull unsigned LL
#define ls i << 1
#define rs (i << 1) + 1
#define INT(t) int t; scanf("%d",&t)

using namespace std;

LL exgcd(LL a,LL b,LL &x,LL &y){
    if(b == 0){
        x = 1;
        y = 0;
        return a;
    }
    LL r = exgcd(b,a % b,x,y);
    LL tmp = x;
    x = y;
    y = tmp - a / b * y;
    return r;
}

int main() {
    LL a,b;
    while(~scanf("%lld%lld",&a,&b)){
        LL x,y;
        LL gcd = exgcd(a,b,x,y);
        if(gcd != 1){
            printf("sorry\n");
            continue;
        }
        x = (x % b + b) % b;
        y = (1 - a * x) / b;
        printf("%lld %lld\n",x,y);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值