HDU - 2619 Love you Ten thousand years (数论,原根)

Love you Ten thousand years

Love you Ten thousand years------Earth's rotation is a day that is the representative of a day I love you. True love, there is no limit and no defects. Earth's revolution once a year, it is on behalf of my love you more than a year. Permanent horizon, and my heart will never change …… 

We say that integer x, 0 < x < n,(n is a odd prime number) is a LovePoint-based-on n if and only if the set { (x i mod n) | 1 <= i <= n-1 } is equal to { 1, ..., n-1 }. For example, the powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a LovePoint-based-on 7. 
Now give you a integer n >= 3(n will not exceed 2 31). 
We say the number of LovePoint-based-on n is the number of days the earth rotating. 
Your task is to calculate the number of days someone loved you. 

Input

Each line of the input contains an integer n. Input is terminated by the end-of-file.

Output

For each n, print a single number that gives the number of days someone loved you.

Sample Input

5

Sample Output

2

题意:问 0 ~ n 有多少个 x 满足,x ^ i % n (1 <= i <= n - 1) 形成的集合为 {1, 2, 3, ... , n - 1}.  n 为 奇素数

关于原根:

设m > 1 且 gcd(a, m) = 1, 则使得a^t ≡ 1(mod m) 成立的最小的正整数t称为a对模m的阶, 记为δm(a)

如果a的阶(mod m)为ϕ(m), 则称a为m的一个原根。 即若δm(a)=ϕ(m), 则称a为m的一个原根。

定理1:若g是m的一个原根,则 g,g^2,⋯,g^ϕ(m)

各数对模m的最小剩余,恰是小于m且与m互素的ϕ(m)个正整数的一个排列。 

定理2:每一个素数p都有ϕ(p−1)个原根。事实上, 每一个数m都有ϕ(ϕ(m))个原根(如果有的话)。即 若 n 为素数  ϕ(p−1) = ϕ(ϕ(p))

这个题中 n 为奇素数,故形成的为完全剩余系。求 n 的原根数量即可。。。。

AC代码:

#include<bits/stdc++.h>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define ull unsigned LL
#define ls i << 1
#define rs (i << 1) + 1
#define INT(t) int t; scanf("%d",&t)

using namespace std;

int Euler(int n){
    int ans = n;
    for(int i = 2;i * i <= n;++ i){
        if(n % i == 0){
            ans = ans / i * (i - 1);
            while(n % i == 0)
                n /= i;
        }
    }
    if(n > 1) ans = ans / n * (n - 1);
    return ans;
}

int main() {
    int n;
    while(~scanf("%d",&n)){
        printf("%d\n",Euler(Euler(n)));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值