HDU 2669 Romantic【扩展欧几里得板子题】

Romantic

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8066 Accepted Submission(s): 3418

Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
…………………………..Write in English class by yifenfei

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print “sorry” instead.

Input

The input contains multiple test cases.
Each case two nonnegative integer a,b (0

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put “sorry” instead.

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3

Author

yifenfei

Source

HDU女生专场公开赛——谁说女子不如男

题意: ax+by = 1,给你a和b,问你让你求出一组数组,使得x > 0,并取最小,如果没有输出sorry

分析: 无解的情况就是gcd(a,b) != 1,然后根据扩展欧几里得的性质,求得符合题意的x即可

参考代码

#include<bits/stdc++.h>

#define ll long long

using namespace std;

void egcd(ll a,ll b,ll &d,ll &x,ll &y) {
    if(!b) {
        d = a;x = 1;y = 0;
    } else {
        egcd(b,a%b,d,y,x);
        y -= x*(a/b);
    }
}

int main(){
    ios_base::sync_with_stdio(0);
    ll a,b;
    while (cin>>a>>b) {
        ll x,y,d;
        egcd(a,b,d,x,y);
        if(d != 1) {
            cout<<"sorry"<<endl;
        } else {
            if(x > 0) {
                cout<<x<<' '<<y<<endl;
            } else {
                while(x <= 0) {
                    x += b;
                    y -= a;
                }
                cout<<x<<' '<<y<<endl;
            }
        }
    }
    return 0;
}
  • 如有错误或遗漏,请私聊下UP,thx
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值