C语言编程100题-3.8

3.8
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
样例输入:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
样例输出:
3 2 1.5 1 2.9 0 3.2

#include <stdio.h>
#include<string.h>
int main()
{
    float a[1001];
    int i,k;
    float temp;
    // 初始化数组
    for(i = 0; i <= 1000; i++){
        a[i] = 0.0f;
    }
    // 分别输入两个多项式
    scanf("%d", &k);
    while(k--){
        scanf("%d%f", &i, &temp);
        a[i] += temp;
    }
    scanf("%d", &k);
    while(k--){
        scanf("%d%f", &i, &temp);
        a[i] += temp;
    }
    // 判断当前多项式的项数
    k = 0;
    for(i = 0; i <= 1000; i++){
        if(a[i]!=0.0){
                k++;
        }
    }
    printf("%d", k);
    // 项数为0则只输出k,且不带空格
    if(k != 0)
        printf(" ");
    for(i=1000; i >= 0; i--){
        if(a[i]!=0.0){
            printf("%d ", i);
            printf("%0.1f", a[i]);
            k--;
            // 输出最后一项后不带空格
            if(k != 0)
                printf(" ");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值