Homework of PE dp 正难则反

http://116.56.140.75:8000/JudgeOnline/problem.php?cid=1075&pid=3

Problem D: Homework of PE
Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 117 Solved: 37
[Submit][Status][Web Board]
Description
At the begining of PE class, the math teacher comes to the class,
and says that the PE teacher has a sick.
So the math teacher gives Nobita a math homework.
The teacher says that s(n) indicates the number of primes in range [1,n].
And the teacher also says that for a permutation of 1-n, if the number x is in the xth position from left,
we say that x is in a correct position.
And then teacher wants to know.
For all permutation of 1-n, how many of them can satisfy that,
for all s(n) primes in range [1,n], there are exactly m of them are in the correct position.
And because the answer is so big, so Nobita needs to know the answer % 1000000007.
Input
The first line contains two integers n and m.
(1<=n<=200, 1<=m<=s(n)).
Output
Output the answer % 1000000007.
Sample Input
5 1
Sample Output
42

F[i][j]表示有i个数(由j个质数和(i-j)个质数)组成,j个质数不在自己位置上的方案数,

正难则反,
f[i][j]=jie[i]-sigma(f[i-k][j-k])(0

#include <bits/stdc++.h>
#define LL long long
using namespace std;
const int MAXN = 205;
const int P = (int)1e9 + 7;
LL jie[MAXN];
LL c[MAXN][MAXN];
LL f[MAXN][MAXN];
bool is_prime(int x){
    for(int i=2;i*i<=x;++i){
        if(x % i == 0)
            return false;
    }
    return true;
}
void init(const int n){
    jie[0] = 1;
    for(int i=1;i<=n;++i)
        jie[i] = jie[i - 1] * i % P;
    for(int i=0;i<=n;++i){
        for(int j=0;j<=i;++j){
            c[i][j] = j == 0 ? 1 : (c[i - 1][j] + c[i - 1][j - 1]) % P;
        }
    }
}
LL solve(const int n,const int m){
    init(n);
    int s = 0;
    for(int i=2;i<=n;++i){
        if(is_prime(i))
            ++s;
    }
    memset(f,0,sizeof f);
    for(int i=1;i<=n;++i){
        for(int j=0;j<=s;++j){
            LL tmp = 0;
            for(int k=1;k<=j;++k)
                (tmp += c[j][k] * f[i - k][j - k] % P) %= P;
            f[i][j] = (jie[i] - tmp + P) % P;
        }
    }
    return f[n - m][s - m] * c[s][m] % P;
}
int main(){
    int n,m;
    while(~scanf("%d %d",&n,&m)){
        printf("%d\n",(int)solve(n,m));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值