Toy Storage(二维计算几何基础)


题目来源: [NWPU][2014][TRN][19]二维计算几何基础 B 题

http://vjudge.net/vjudge/contest/view.action?cid=54080#problem/B



作者:npufz

题目:

B - Toy Storage
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
typedef  struct  board
{
    double  x1;
    double  x2;
} bo;
inline  bool cross(const double  &x1,const double  &x2,const  double  &x3,const double &x4,const double y1,const double  y2,const double x0,const double y0)
{
    double  m1,m2;
    bool  flag;
    m1=x1+(x2-x1)*(y0-y1)/(y2-y1);
    m2=x3+(x4-x3)*(y0-y1)/(y2-y1);
    if((m1<=x0)&&(m2>=x0)) flag=true;
    else  flag=false;
    return  flag;
}
bool cmp(board x,board y)
{
    return x.x1<y.x1;
}
int main()
{
    bo  b[2050];
    int i,j,m,n;
    double x[2],y[2],x0,y0;
    int cnt[2050];
    while(scanf("%d",&n),n)
    {
        scanf("%d%lf%lf%lf%lf",&m,&x[0],&y[0],&x[1],&y[1]);
        b[0].x1=x[0];
        b[0].x2=x[0];
        b[n+1].x1=x[1];
        b[n+1].x2=x[1];
        for(i=1;i<=n;i++)
            scanf("%lf%lf",&b[i].x1,&b[i].x2);
        memset(cnt,0,sizeof(cnt));
        sort(b,b+n+1,cmp);
        for(i=0;i<m;i++)
        {
            scanf("%lf%lf",&x0,&y0);
            for(j=0;j<=n;j++)
            {
                if(cross(b[j].x1,b[j].x2,b[j+1].x1,b[j+1].x2,y[0],y[1],x0,y0))
                {
                    cnt[j]++;
                    break;
                }
            }
        }
        int cnt1[2050];
        memset (cnt1,0,sizeof(cnt1));
       for(i=0;i<=n;i++)
       {
       cnt1[cnt[i]]++;
       }
      printf("Box\n");
       for(i=1;i<=m;i++)
       {
           if(cnt1[i]>0)
        printf("%d: %d\n",i,cnt1[i]);
       }
   }
return 0;
}


反思:

其实思路很简单,就是代码 的实现,每次判断一下玩具在不在两个板之间就可以了,这里由于任意两个板不交叉,所以可以先对板按照一个端点的X坐标进行排序,这样就OK了,然后处理起来就很方便了,由于数据量很小,N*N的复杂度就能过

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值