Song Jiang's rank list【理解题意】

A - Song Jiang's rank list
Time Limit:1000MS     Memory Limit:512000KB     64bit IO Format:%I64d & %I64u

Description

《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai'an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from different backgrounds (including scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader. 

In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.
 

Input

There are no more than 20 test cases. 

For each test case: 

The first line is an integer N (0<N<200), indicating that there are N outlaws. 

Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique. 

The next line is an integer M (0<M<200) ,indicating that there are M queries. 

Then M queries follow. Each query is a line containing an outlaw's name. 
The input ends with n = 0
 

Output

For each test case, print the rank list first. For this part in the output ,each line contains an outlaw's name and the number of enemies he killed. 

Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed that each query has an answer for it.
 

Sample Input

       
       
5 WuSong 12 LuZhishen 12 SongJiang 13 LuJunyi 1 HuaRong 15 5 WuSong LuJunyi LuZhishen HuaRong SongJiang 0
 

Sample Output

       
       
HuaRong 15 SongJiang 13 LuZhishen 12 WuSong 12 LuJunyi 1 3 2 5 3 1 2
 

 
 
好吧,题意理解错误,,,
输入后 :排序,打印,然后开始查询,,原来3 是指他并列第三,2 是指他上面一共有两个和他杀敌人数相同的人。
还有,比较字符串大小不是直接比较的,而是应该用函数strcmp(st1,st2);
代码如下:
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct mmd
{
    char name[55];
    int num;
} a[210];
int cmp(mmd a,mmd b)
{   if(a.num==b.num)
    {return strcmp(a.name,b.name)<0?true:false;

    }

   else
    return a.num>b.num;
}

int main()
{
    int n,m,k;
    char mz[55];
    while(scanf("%d",&n)&&n!=0)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%s%d",a[i].name,&a[i].num);

        }
        sort(a,a+n,cmp);
        for(int r=0;r<n;r++)
        {
            printf("%s %d\n",a[r].name,a[r].num);
        }
        scanf("%d",&m);
        for(int j=0;j<m;j++)
        {
            scanf("%s",mz);
           for(int i=0;i<n;i++)
           {
               if(strcmp(mz,a[i].name)==0)
               {    k=i;
                  int count=0;
                  for(int w=k;w>=0;w--)
                 {
                   if(a[k].num==a[w].num)
                   count++;
                  // printf("**%d\n",count);
                   }
                  if(count!=1)
                  printf("%d% d\n",k+1-(count-1),count);
                  else
                   printf("%d\n",k+1);

               }


           }

        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值