poj 1753 Flip Game【枚举+dfs】

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36225 Accepted: 15788

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

看到这题想了半天我并没有什么思路,想不到后看了下别人的,说是枚举+dfs可以过,于是我就自己写写,调了好久,终于过了

#include<stdio.h>
int dir[5][2]= {0,0,1,0,-1,0,0,1,0,-1};
int min,count;
char map[10][10];
void dfs(int a,int b)
{
    int  x,y,p,q;
    x=y=0;
    for(int t=0; t<4; t++)//判断是否全白或全黑
        for(int r=0; r<4; r++)
            if(map[t][r]=='b')
                x++;
            else if(map[t][r]=='w')
                y++;
    if(x==0||y==0)
        min=min<count?min:count;
    for(int i=a; i<4; i++)//开始搜啦
    {
        if(i!=a) b=0;//注意这里哦,下一行的所有都要找哦
        for(int j=b; j<4; j++)
        {
            count++;
            for(int k=0; k<5; k++)//这个点本身也要变哦
            {
                q=i+dir[k][0];
                p=j+dir[k][1];
                if(p>=0&&p<4&&q>=0&&q<4)
                {
                    if(map[q][p]=='b')

                        map[q][p]='w';
                    else if( map[q][p]=='w')
                        map[q][p]='b';
                }

            }

            if(j==3)
                dfs(i+1,0);
            else
                dfs(i,j+1);
            count--;
            for(int k1=0; k1<5; k1++)
            {
                q=i+dir[k1][0];
                p=j+dir[k1][1];
                if(p>=0&&p<4&&q>=0&&q<4)
                {
                    if(map[q][p]=='b')
                        map[q][p]='w';
                    else if( map[q][p]=='w')
                        map[q][p]='b';
                }
            }
        }
    }
}
int main()
{
    int m,n;
    for(m=0; m<4; m++)
    {
        for(n=0; n<4; n++)
        {
            scanf("%c",&map[m][n]);
        }
        if(m<3)
            getchar();
    }
    min=20;
    count=0;
    dfs(0,0);
    if(min<=16)
        printf("%d\n",min);
    else
        printf("Impossible\n");
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值