迷宫问题(dfs)

H - 迷宫问题
Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

定义一个二维数组:
int maze[5][5] = {

 0, 1, 0, 0, 0,

 0, 1, 0, 1, 0,

 0, 0, 0, 0, 0,

 0, 1, 1, 1, 0,

 0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

ACdaima

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>

using namespace std;

struct Node
{
    int x, y;
};

const int dir[4][2] = { {0, 1}, {1, 0}, {-1, 0}, {0, -1} };

int maze[5][5];
int vis[5][5];
int rec[5][5];

int print( int i, int j )
{
    if( 0 == i && 0 == j )
    {
        printf("(%d, %d)\n", i, j);
        return 0;
    }
    print(i-dir[ rec[i][j] ][1], j-dir[ rec[i][j] ][0]);
    printf("(%d, %d)\n", i, j);
}

int main()
{
    memset(vis, 0, sizeof(vis));
    memset(maze, 0, sizeof(maze));
    memset(rec, 0, sizeof(rec));
    int i, j, dx, dy, flag = 0;
    Node temp, good;
    queue <Node> q;
    for( i=0; i<5; i++ )
        for( j=0; j<5; j++ )
        scanf("%d", &maze[i][j]);
    temp.x = 0;
    temp.y = 0;
    vis[0][0] = 1;
    q.push(temp);
    while( !q.empty() )
    {
        temp = q.front();
        q.pop();
        for( i=0; i<4; i++ )
        {
            dx = temp.x+dir[i][1];
            dy = temp.y+dir[i][0];
            good.x = dx;
            good.y = dy;
            if( dx>=0 && dy>=0 && dx<5 && dy<5 && !vis[dx][dy] && 0 == maze[dx][dy] )
            {
                vis[dx][dy] = 1;
                rec[dx][dy] = i;
                if( 4 == dx && 4== dy )
                {
                    flag = 1;
                    break;
                }
                q.push(good);
            }
        }
        if( flag )
            break;
    }
    print(4, 4);
    return 0;
}

当你不会做一道题的时候,你就可以学到新东西~~
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值