Minimum Inversion Number(线段树)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17705    Accepted Submission(s): 10744



Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1698  1540  1542  1255  1754

AC代码:
#include <iostream>
#include <cstdio>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <utility>
#include <algorithm>
#define lson l, m, rt << 1
#define rson m+1, r, rt << 1 | 1
using namespace std;

const int maxn = 5500 << 2;
int a[maxn];
int seq[maxn];

void update(int p, int l, int r, int rt)
{
    if (l == r)
    {
        a[rt]++;
    }
    else
    {
        int m = (l + r) >> 1;
        if (p <= m)
        {
            update(p, lson);
        }
        if (p > m)
        {
            update(p, rson);
        }
        a[rt] = a[rt << 1] + a[rt << 1 | 1];
    }
}

int query(int ql, int qr, int l, int r, int rt)
{
    int sum = 0;
    if (l >= ql && r <= qr)
    {
        return a[rt];
    }
    else
    {
        int m = (l + r) >> 1;
        if (ql <= m)
        {
            sum += query(ql, qr, lson);
        }
        if (qr > m)
        {
            sum += query(ql, qr, rson);
        }
        return sum;
    }
}

int main()
{
    int n;
    int ans = 0;
    int inv = 0;
    while (scanf("%d", &n) != EOF)
    {
        inv = 0;
        memset(a, 0, sizeof(a));
        memset(seq, 0, sizeof(seq));
        for (int i=0; i<n; i++)
        {
            scanf("%d", &seq[i]);
        }
        for (int i=0; i<n; i++)
        {
            inv += query(seq[i], n-1, 0, n-1, 1);  //大神告诉我: rt只与上一个rt有关, 与比较范围无关~
            update(seq[i], 0, n-1, 1);
        }
        ans = inv;
        //cout << inv << endl;
        for (int i=0; i<n; i++)
        {
            inv = inv - seq[i] + (n - seq[i] - 1);
            ans = min (inv, ans);
        }
        cout << ans << endl;
    }
    return 0;
}
实力坑自己,  无语到不想多说(ˇˍˇ) ~,,这道题想了好久好久后决定还是看题解, (⊙v⊙)嗯, 看题解都想了好一会呢, 初学线段树, 请各位君多多包含╮(╯▽╰)╭~
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值